解决作系统升级后的 NVIDIA 安装程序故障

Summary: 以下文章介绍了四种方法,用于解决升级 Windows 10 后 NVIDIA 安装程序失败的问题。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

升级 Windows 10 后,NVIDIA 安装程序在每次尝试安装时都会出错

 

有几份关于 NVIDIA 安装程序在升级到最新版本的 Windows 10作系统后失败的报告。本指南可帮助您解决戴尔计算机上的此问题。

Cause

工程部门确定这是软件问题。排除显卡驱动程序,将防病毒软件排除在外,并终止任何正在运行的 NVIDIA 进程。

Resolution

提醒:使用以下方法时,需要计算机上的管理员权限。

按顺序执行以下每种方法,直到您的问题得到解决。

提醒:开始更新之前,请执行以下作:
  • 备份所有个人数据。有关详细信息,请参阅:备份和恢复
  • 如果笔记本电脑上运行更新,请连接交流适配器。
  1. 更新 NVIDIA 驱动程序:

    1. 将计算机上的驱动程序更新到最新版本可解决此问题。要下载并安装驱动程序,请参阅:如何下载和安装戴尔驱动程序和固件

某些防病毒应用程序可能会导致 NVIDIA 安装程序失败。在运行特定安装程序时临时关闭防病毒软件可能会解决此问题:

  1. 在戴尔平台上,防病毒软件会在 Windows作系统的系统任务栏中显示一个图标。

  2. 右键单击该图标可打开更多选项,具体取决于防病毒软件制造商:

    • 打开防病毒应用程序或代理以将其关闭

    • 关闭活动扫描程序

    • 关闭防病毒软件,直至下次重新启动

  3. 安装完成后,请确保重新打开防病毒软件。不要让您的设备不受保护。

冗余的 NVIDIA 文件和进程可能会导致安装失败:

  1. 通过右键单击任务栏的空白部分或同时按住 CTRLShiftEsc 键,然后从显示的菜单中选择 任务管理器 ,打开任务管理器:

    1. 单击 进程 选项卡。

    2. 选择与 NVIDIA 相关的每个进程

    3. 右键单击各项并选择 End Task 以关闭进程。

  2. 转至启动驱动器文件夹并删除以下文件:

    • C:\windows\system32\DRiverStore\FileRepository\nvdsp.inf file

    • C:\windows\system32\DRiverStore\FileRepository\nv_lh file

    • C:\windows\system32\DRiverStore\FileRepository\nvoclock file

    • C:\Program Files\NVIDIA Corporation\

    • C:\Program Files(x86)\NVIDIA Corporation\

  3. 重新启动设备。

  4. 尝试在 自定义 安装中重新运行 NVIDIA 安装程序。

请按照以下步骤从 NVIDIA 安装程序运行全新安装:

  1. 让系统处于空闲状态 20 分钟,以确保 Windows 已完成升级后的作系统的所有更新。

  2. 与方法 I 一样,将最新版本的驱动程序下载到您的计算机。

  3. 右键单击下载的文件并选择 Run as Administrator(以管理员身份运行),以管理员权限运行驱动程序解压缩/安装。

  4. 按照屏幕上的说明进入 安装选项 屏幕。

  5. 选择 自定义 ,然后选中 执行全新安装旁边的标记。

  6. 安装完成后,重新启动计算机。

如果这不能解决您的问题,请联系技术支持:


返回页首

Article Properties
Article Number: 000147364
Article Type: Solution
Last Modified: 02 Oct 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.