Avamar: Há um problema com a configuração do agente RabbitMQ local.

Summary: O Avamar está relatando um erro: Há um problema com a configuração do agente RabbitMQ local."

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

A interface do usuário do Management Console Server (MCS) relata o seguinte erro RabbitMQ a cada 5 minutos:

There is a problem with the configuration of the local RabbitMQ broker. 
 

O log (/data01/avamar/var/rabbitmq/log/rabbit@localhost.log) relata Não autorizado, o que significa que há um problema de permissão com a conta de convidado do RabbitMQ:

=ERROR REPORT==== 10-Nov-2019::18:14:02 ===
webmachine error: path="/api/definitions"
"Unauthorized"

=ERROR REPORT==== 10-Nov-2019::18:19:02 ===
webmachine error: path="/api/definitions"
"Unauthorized"
 

Reiniciando o rabbitmqctl-server Não resolve o problema.

Cause

Há um problema com os privilégios ou permissões da conta de convidado do RabbitMQ. 

Resolution

1. Faça log-in no Avamar Utility Node como administrador.

2. Eleve para root.

3. Reinicie o serviço de mensagens usando os comandos abaixo:

msgbrokerctl.pl --stop 
msgbrokerctl.pl --start 
 

Durante a inicialização, a saída mostra que as permissões e senhas da conta estão sendo abordadas:

INFO: Starting messaging service.
INFO: Started messaging service.
INFO: Create the rabbitmq user Avamar successfully.
INFO: Change password and degrade the permission for rabbitmq guest user successfully.
INFO: Create the vhost for proxy deploy manager successfully.
INFO: Add the permission for user Avamar successfully.
 

4. Confirme os eventos na interface do usuário relacionados ao RabbitMQ.

5. Monitore a grade para confirmar se o problema foi resolvido. 

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000165322
Article Type: Solution
Last Modified: 16 Oct 2025
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.