Avamar: Det finns ett problem med konfigurationen av den lokala RabbitMQ-koordinatorn.

Summary: Avamar rapporterar ett fel: Det finns ett problem med konfigurationen av den lokala RabbitMQ-mäklaren."

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Användargränssnittet för Management Console Server (MCS) rapporterar följande RabbitMQ-fel var 5:e minut:

There is a problem with the configuration of the local RabbitMQ broker. 
 

Loggen (/data01/avamar/var/rabbitmq/log/rabbit@localhost.log) rapporterar Obehörig, vilket innebär att det finns ett behörighetsproblem med RabbitMQ-gästkontot:

=ERROR REPORT==== 10-Nov-2019::18:14:02 ===
webmachine error: path="/api/definitions"
"Unauthorized"

=ERROR REPORT==== 10-Nov-2019::18:19:02 ===
webmachine error: path="/api/definitions"
"Unauthorized"
 

Startar om rabbitmqctl-server löser inte problemet.

Cause

Det finns ett problem med privilegiet eller behörigheterna för RabbitMQ-gästkontot. 

Resolution

1. Logga in som administratör på Avamar-verktygsnoden.

2. Höj till rot.

3. Starta om meddelandetjänsten med hjälp av kommandona nedan:

msgbrokerctl.pl --stop 
msgbrokerctl.pl --start 
 

Under starten visar utdata att kontobehörigheterna och lösenorden åtgärdas:

INFO: Starting messaging service.
INFO: Started messaging service.
INFO: Create the rabbitmq user Avamar successfully.
INFO: Change password and degrade the permission for rabbitmq guest user successfully.
INFO: Create the vhost for proxy deploy manager successfully.
INFO: Add the permission for user Avamar successfully.
 

4. Bekräfta händelserna i användargränssnittet som är relaterade till RabbitMQ.

5. Övervaka rutnätet för att bekräfta att problemet är löst. 

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000165322
Article Type: Solution
Last Modified: 16 Oct 2025
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.