NetWorker: Se agota el tiempo de espera de las consultas de respaldos de la API REST

Summary: Se agota el tiempo de espera de las consultas de respaldos de la API REST

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Está intentando consultar respaldos de NetWorker con API REST, pero se agota el tiempo de espera de algunos recursos.
  • Está utilizando la DIRECCIÓN URL /nwrestapi/v3/global/clients/client_id/backups .
  • El recurso que se consulta es para un VMware vCenter.
  • El comportamiento se puede producir mediante un script o con una sola llamada REST.
  • /nsr/logs/restapi/restapi.log puede informar el estado 500 (error interno del servidor) para el recurso que se consulta. Este es un mensaje de error genérico.

Cause

Este comportamiento puede ocurrir cuando se consultan vCenters debido a la cantidad de respaldos y metadatos que se consultan para un único recurso.

Si está creando scripts para los comandos de la API REST y hay vCenters en la consulta mediante la URL "/clients/client_id/backups", este comportamiento también puede aparecer en otros recursos debido a una posible pérdida de memoria.

Resolution

Utilice la siguiente llamada de API REST para consultar respaldos de VMware: https:// NetWorker_Server_Name:9090/nwrestapi/v3/global/vmware/vcenters/Hypervisor_Resource_Name/protectedvms/VM_UUID/backups
Donde Hypervisor_Resource_Name es el nombre de vCenter, como se muestra en NetWorker.

Ejemplo:
kA23a0000000BiWCAU_2_0
Nota: Estado 200 indica que el comando se recibió y respondió correctamente.

Puede continuar utilizando la URL https:// NetWorker_Server_Name:9090/nwrestapi/v3/global/clients/Client_ID/backups para los clientes tradicionales de NetWorker.

Additional Information

El soporte de NetWorker solo puede manejar problemas de reparación de fallas con la API REST y no es compatible con ningún script personalizado que se utilice para llamar a la API REST. 

https://developer.dell.com/apis/2378/versions/v3/docs/GettingStarted.md

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000169971
Article Type: Solution
Last Modified: 03 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.