IDPA 2.1: Il ripristino NDMP ha esito negativo con errore "Backup is invalid or not an NDMP backup"

Summary: Il ripristino NDMP su IDPA versione 2.1 ha esito negativo con errore "Backup is invalid or not an NDMP backup". Una volta verificato, il backup è valido. Il problema si verifica a causa di un problema di Data Domain 209416 sulla libreria DD Boost 3.4.0 integrata con Avamar versione 7.5.0-183. Questo problema può essere visualizzato quando sono abilitati gli IFGroups di Data Domain e la configurazione di sicurezza della sessione è impostata sulla modalità dual, single o mixed. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Nel registro del processo di ripristino NDMP possono essere visualizzati i seguenti errori: 
2018-12-06 15:03:04 avndmp Info <6444>: [avndmp_assist] Plugin exited with 'code 157: miscellaneous error'
2018-12-06 15:03:04 avndmp Error <11799>: [avndmp_assist] Backup is invalid or not a NDMP backup.
2018-12-06 15:03:04 avndmp Info <11780>: [avndmp_ctl_sup] Global avndmp_assist exit code is: 161
Per verificare la versione del plug-in DD Boost su Avamar, eseguire il seguente comando:
strings /usr/local/avamar/lib/libDDBoost.so | grep "[0-9]\.[0-9]\.[0-9]\.[0-9]"

Or  

grep -i engine ddrmaint.log | tail -1
Nel registro DDFS (/ddr/var/log/debug/ddfs.info) su Data Domain, vengono visualizzati i seguenti errori:
12/06 15:02:45.099 (tid 0x90a9b30): nfs_rpc_svc_idx0 accepted cfa 255 from 10.12.255.85:39910
12/06 15:02:45.103 (tid 0x7ff35b151220): nfsproc3_ostmntsec_3_svc: connection failed permission (corrupted credentials) from host 10.12.255.85 - ost_decrypt_mnt_sec_request(): failed to finalize plain text (101077092, error:06065064:digital envelope routines:EVP_DecryptFinal_ex:bad decrypt)
 
Nota: È possibile cercare l'indirizzo IP dell'accelerator node NDMP nei registri ddfs.info di Data Domain per confermare il problema.
 
Ciò conferma che Data Domain non è stato in grado di decrittografare la password fornita per il ripristino NDMP.

Cause

Avamar Server 7.5.0 utilizza la libreria DD Boost versione 3.4.0.2. Questo problema esiste nella libreria DD Boost 3.4.0 ed è stato risolto nella versione 3.4.1.

Avamar Server versione 7.5.1 è dotato della libreria DD Boost versione 3.4.1.1 integrata. 

A partire dal plug-in versione 3.4, Data Domain esegue l'autenticazione utilizzando chiavi precondivise (PSK) generate dalla password. Il client genera una PSK dalla password fornita dall'applicazione, crittografa alcune informazioni di autenticazione e le invia a DDR. Il DDR tenta di generare la stessa PSK (poiché conosce già la password di un utente) e di decrittografare i contenuti inviati e convalidati dal client.

Con DD Boost ifgroup abilitato, Data Domain rientra nel percorso riconnesso, che chiama il percorso di connessione PSK e si basa sulla password crypt_hash archiviata nella struttura nfs_conn. Nel plug-in DD Boost 3.4.0.2, tuttavia, Data Domain non genera nuovamente la password crypt_hash durante la riconnessione. La chiave PSK non è la stessa sul client e sul DDR, da qui l'errore di decrittografia.

Resolution

Soluzione alternativa:
Utilizzare uno dei seguenti metodi per aggirare questo problema.    

Metodo 1.
Utilizzare l'autenticazione nome utente-password. (Disabilitare la sicurezza della sessione su Avamar Server)
 
Seguire le informazioni riportate nell'articolo 000067229: Avamar 7.3 e versioni successive: I backup o le repliche hanno esito negativo con errore di certificato per scaricare l'avp SessionSecurityConfiguration (per visualizzare questo articolo potrebbe essere necessario accedere come utente registrato del supporto Dell):

  • Controlli preliminari prima dell'installazione di avp:   
    • Verificare che le attività di manutenzione, backup, ripristino e replica non siano in esecuzione durante l'installazione di SessionSecurityConfiguration avp
    • Verifica che l'Avamar Server abbia un checkpoint corrente
  1. Passare alla pagina Avamar Installation Manager (AVI) (http://< IP/fqdn di Avamar Server/avi) in un web browser e accedere come utente root:    
    1. Nella scheda Maintenance , selezionare SessionSecurityConfiguration e cliccare su Run:    
schermata di SessionSecurityConfiguration
  1. Selezionare Disabled mode dal menu a discesa nella scheda Security settings:    
screenshot che mostra la sicurezza disattivata
  1. Cliccare su Continue.

Seguire le informazioni riportate nell'articolo 000222279: Avamar: gestione delle impostazioni di sicurezza delle sessioni con AVP (Avinstaller Installation Package) (in inglese)


Metodo 2. 
Aggiornare il catalogo client Avamar alla versione 7.5.1-101, quindi aggiornare l'accelerator node NDMP alla stessa versione (7.5.1).

Metodo 3:
Disabilitazione di DD Boost ifgroups su Data Domain.
 
Nota: Invalidante ifgroups può influire direttamente sulle prestazioni di backup e ripristino.
 
  1. Accedere a Data Domain:   
    1. Eseguire il comando seguente per visualizzare il file esistente ifgroups in Data Domain: 
ddboost ifgroup show config all
Confermare quale ifgroups vengono utilizzati per i backup. Prendere nota del ifgroup nome.

Esempio:
Group-name    Status        Interface      Clients     Replication
-----------   --------      ---------      -------     -----------
default       disabled           0         1             0
backupgroup   enabled            2         0             0
-----------   --------      ---------      -------     -----------

Group-name    Status     Interfaces
-----------   -------   -----------
backupgroup   enabled   10.x.x.x
backupgroup   enabled   192.x.x.x
-----------   -------   -----------
 
Nota: Nell'esempio precedente, il metodo ifgroup denominato backupgroup è abilitato e in uso.
 
  1. Eseguire il seguente comando per disabilitare ifgroup incerto: 
ddboost ifgroup disable <group-name>

Affected Products

Integrated Data Protection Appliance Family

Products

Integrated Data Protection Appliance Family, Integrated Data Protection Appliance Software
Article Properties
Article Number: 000170441
Article Type: Solution
Last Modified: 13 Aug 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.