SourceOne for File Systems : L’activité « Archivage de fichiers - Historique » échoue avec le message « Analyse XML : ligne 2 »

Summary: SourceOne for File Systems : Échec de l’activité SourceOne « File archive - Historical » avec l’erreur « XML parsing : line 2, character 1061, illegal xml character Native error : 9420 SQL State : 42000" ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

La tâche parent SourceOne File Archive (JBS) échoue lors de la création de tâches enfants (JBC) en fonction des sources de données sélectionnées lors de la création de l’activité « File Archive - Historical ».
Si de nombreuses tâches étaient censées être créées par la tâche parente, certaines tâches enfants auraient déjà commencé à être traitées avant que le problème ne soit rencontré.
Les tâches parent et enfant arrêtent le traitement car le service SourceOne Job Dispatcher aurait demandé aux tâches de s’arrêter après qu’une erreur ait été rencontrée.

Un message d’erreur similaire à ce qui suit se trouve dans le fichier log détaillé SOFileArchiveJBS.log sur le serveur de travail SourceOne qui aurait traité la tâche parent pour l’activité qui a échoué :

95216|P2D0|T1274|2017/04/13 23:18:46:531|CoExTask::Save|ERROR|System call failed. (0x86040100) [SOFileArchiveJBS, CoExTask.cpp(947).CoExTask::Save] >System call failed. (0x86040100) [SOFileArchiveJBS, CoExJDFDB.cpp(905).CoExJDFDB::ExecuteCmdForID] >System call failed. (0x86040100) [SOFileArchiveJBS, CoExJDFDB.h(514).CoExJDFDB::ExecuteSP] >System call failed. (0x86040100) Unknown error (0x800424CC) [SOFileArchiveJBS, CoExJDFDB.h(509).CoExJDFDB::ExecuteSP] >{XML parsing: line 2, character 1061, illegal xml character Native error: 9420 SQL State: 42000 } |CoExTask.cpp(947)|Job Id: 209023; Activity Name: FileShareProcessing; Activity Id: 10159; Activity Type: -1788567307; ES1WORKER


 

Cause

Un nom de dossier mal formé est présent sur le système de fichiers qui a été analysé par la tâche parent SourceOne File Archive.
Ce dossier devient une partie du fichier XML à enregistrer dans la base de données d’activité SourceOne pour la création d’une tâche enfant.
L’enregistrement du fichier XML dans la base de données d’activités échoue avec le message d’erreur mentionné dans la section problème ci-dessus.

Resolution

Identifiez et renommez le dossier à l’origine du problème.

Pour identifier le nom du dossier à l’origine du problème :

  1. Sur le(s) serveur(s) de travail SourceOne avec le rôle « File Archive - History », définissez le niveau de verbosité du composant SOFileArchiveJBS sur 8 (décimal). Pour le modifier :  
    • Lancer l’Éditeur du Registre (regedit.exe)
    • Accédez à "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\EMC\SourceOne\TraceLogs\SOFileArchiveJBS\Settings»
    • Modifiez la valeur de TraceVerbosity à 8 (décimal).
    • Fermer l’Éditeur du Registre
  2. Créez/exécutez l’activité « File Archive - Historical » qui échoue avec le message d’erreur mentionné ci-dessus. 
  3. Lorsque les tâches parentes créées par l’activité de l’étape 2 sont marquées comme ayant échoué, ouvrez SOFileArchiveJBS.log fichier sur le serveur de travail SourceOne qui a traité la tâche parent en échec.
  4. En commençant par le bas où vous remplissez, recherchez le message d’erreur mentionné ci-dessous, commencez à rechercher les dossiers qui ont été récemment analysés par SOFileArchiveJBS.exe processus. Vous devriez trouver un dossier au nom étrange similaire à ce qui suit :
2077389|P2D0|T1274|2017/04/13 23:18:43:894|CSOFileArchiveJBS::ScanCurrentDirectory|VERBOSE|Push for path: \\?\UNC\LabMachine\E$\katwar\Downloads\       , index: 206912|SOFileArchiveJBS.cpp(3112)|Job Id: -1; Activity Name: ES1Worker; Activity Id: -1; Activity Type: -1; ES1WORKER
  1. Renommez le dossier identifié à l’étape 4 et exécutez à nouveau l’activité qui a échoué.

Affected Products

SourceOne for File Systems

Products

SourceOne, SourceOne for File Systems
Article Properties
Article Number: 000171396
Article Type: Solution
Last Modified: 02 Sept 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.