Isilon: Stan łączności bramki to Rozłączony, błąd wewnętrzny 401 Nieautoryzowane kody odpowiedzi

Summary: Stan łączności bramki to Rozłączono i widoczny jest błąd wewnętrzny 401 Nieautoryzowane kody odpowiedzi (możliwość naprawienia przez użytkownika).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Stan łączności bramy klastra, która wcześniej działała i była podłączona, pokazuje Rozłączenie.

401 Unauthorized Z bramki zabezpieczeń są widoczne odpowiedzi, które NIE są związane z nieprawidłową nazwą użytkownika i hasłem.

W przypadku klastrów Isilon korzystających z bramki zabezpieczeń isi esrs view pokazuje, że stan łączności bramki jest rozłączony. Wcześniej konfiguracja działała prawidłowo.

Próby wyłączenia i ponownego włączenia isi_esrs_d i isi_rsapi_d Nie pomagaj w przywróceniu łączności.

Próbuje zmodyfikować konfigurację za pomocą username i próbuje wyłączyć bramkę zabezpieczeń (--enabled=false) w nadziei na odtworzenie konfiguracji kończy się niepowodzeniem.

Podobny błąd występuje również podczas wydawania isi esrs modify --enabled==false :

Internal error:
ESRSBadCodeError: ESRS Delete Device failed. Error response code from gateway: 401, Unauthorized. Response dictionary was: {{'http_response_code': 401, 'curl_trace': "*   Trying 1.2.3.4:9443...\n* TCP_NODELAY set\n* Name '1.2.3.4' family 2 resolved to '1.2.3.4' family 2\n* Local port: 0\n* Connected to 1.2.3.4 (1.2.3.4) port 9443 (#0)\n* ALPN, offering http/1.1\n* Cipher selection: ALL:!EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH\n* SSL connection using TLSv1.2 / ECDHE-RSA-AES256-GCM-SHA384\n* ALPN, server accepted to use http/1.1\n* Server certificate:\n*  subject: C=US; ST=MA; L=SO; O=EMC; OU=ESRS; CN=myname\n*  start date: Dec  4 12:20:29 2019 GMT\n*  expire date: Dec  4 12:20:29 2039 GMT\n*  issuer: C=US; ST=MA; L=SO; O=EMC; OU=ESRS; CN=myname\n*  SSL certificate verify result: unable to get local issuer certificate (20), continuing anyway.\n> DELETE /esrs/v1/devices/ISILON-GW/ELMISLxxxxxxxx HTTP/1.1\r\nHost: 1.2.3.4:9443\r\nUser-Agent: PycURL/7.43.0 libcurl/7.66.0 OpenSSL/1.0.2r-fips zlib/1.2.11\r\nAccept: */*\r\nAuthorization: ISILON-GW:ELMISLxxxxxxxx:keykeykeyGYskKOwNZQg7SGOgC8=,domain=Device\r\nDate: Wed, 04 Nov 2020 19:15:47 GMT\r\n\r\n* Mark bundle as not supporting multiuse\n< HTTP/1.1 401 Unauthorized\r\n< Date: Wed, 04 Nov 2020 19:15:48 GMT\r\n< Server: Apache PivotalWebServer\r\n< Strict-Transport-Security: max-age=31536000; includeSubDomains;\r\n< Content-Security-Policy: frame-ancestors 'self'\r\n< Transfer-Encoding: chunked\r\n< \r\n* Connection #0 to host 1.2.3.4 left intact\n"}}


Jeśli komunikat 401 zawiera ciąg tekstowy Invalid username and password, ten artykuł NIE ma zastosowania. 

Cause

Problem wynika z niezgodności klucza urządzenia usług Secure Connect Gateway pierwotnie przydzielonego Isilon.

W powyższej odpowiedzi należy zauważyć, że Isilon wydaje HTTP DELETE :
DELETE /esrs/v1/devices/ISILON-GW/ELMISLxxxxxxxx

Klucz urządzenia jest używany do uwierzytelniania komunikacji między Isilon a bramką zabezpieczeń:
Authorization: ISILON-GW:ELMISLxxxxxxxx:keykeykeyGYskKOwNZQg7SGOgC8=

Jeśli brama została ponownie zainstalowana lub utracono klucz urządzenia z innego powodu, uwierzytelnianie interfejsu API REST-API przy użyciu klucza zakończy się niepowodzeniem z 401 Unauthorized błąd.

Czasami, jeśli nie można ustalić stanu bramki zabezpieczeń, można zaangażować dział pomocy technicznej firmy Dell w celu zbadania problemu. Klucze urządzeń zostaną utracone w przypadku ponownej instalacji bramy, ale mogą również zostać utracone, jeśli brama zostanie przywrócona do starej migawki (przed utworzeniem lub aktualizacją klucza). Ponadto, jeśli w bramce zabezpieczeń zabraknie miejsca na dysku, a w tym czasie zostanie dodane nowe urządzenie, nie będzie można rozszerzyć bazy danych kluczy urządzeń w bramce zabezpieczeń.

Resolution

Najprostszym sposobem i najbardziej prawdopodobnym rozwiązaniem jest uruchomienie poniższych poleceń w celu wyłączenia konfiguracji i wykonania nowej rejestracji w celu wygenerowania nowego klucza urządzenia dla Isilon. Polecenie --force Flaga instruuje Isilon, aby wyłączył usługi bramki zabezpieczeń bez próby skontaktowania się z bramką w celu wyrejestrowania.

isi esrs modify --enabled=false --force
isi esrs modify --enabled=true --username=DellSupportEmail --password=MYPASS


Jeżeli te polecenia nie działają, można zaangażować dział pomocy technicznej firmy Dell w celu ręcznego wyczyszczenia klucza i zresetowania komunikacji między bramką zabezpieczeń a klastrem Isilon. Otwórz zgłoszenie serwisowe z wyceną tego artykułu.

Doświadczony administrator musi wykonać następujące polecenia, aby wyłączyć odpowiednie usługi w klastrze, ręcznie wyłączyć bramkę zabezpieczeń oraz wyczyścić istniejący klucz uwierzytelniania po stronie klastra.
 

Przestroga: Należy zachować ostrożność i nie należy wykonywać żadnych czynności, jeśli wykonanie poleceń wydaje się zbyt skomplikowane! Aby uzyskać pomoc techniczną, skontaktuj się z firmą Dell, korzystając z witryny Dell Support .
  1. Jeśli odpowiednie usługi działają, należy je wyłączyć. Usługi te reprezentują demony, które uruchamiają usługę Secure Connect Gateway i usługę REST-API dla łączności Secure Connect Gateway. Wyłączenie tych usług nie wpływa na dostęp klienta do klastra.
isi services -a isi_esrs_d disable
isi services -a isi_rsapi_d disable
  1. Ręcznie wymuś wyłączenie bramki zabezpieczeń.
isi_gconfig -t esrs esrs.enabled=false
  1. Wyczyszczenie klucza używanego do komunikacji.
isi_gconfig -t esrs esrs.esrs_api_key=""

NOTE: if secondary Gateway is configured, clear the API key for secondary Gateway using command below:
isi_gconfig -t esrs esrs.secondary_esrs_api_key=""
  1. Włącz TYLKO funkcję rsapi .
isi services -a isi_rsapi_d enable
  1. Użyj normalnych poleceń, aby włączyć konfigurację bramki zabezpieczeń.
isi esrs modify --enabled=true --username=DELL-Support-Account --password=MYPASS
  1. Jeśli upłynie limit czasu polecenia oczekiwania na odpowiedź REST , wprowadź następujące polecenie:
isi --timeout=600 esrs modify --enabled=true --username=DELL-Support-Account --password=MYPASS
  1. Jeśli polecenie nadal wyświetla błędy, rozpocznij nowe spotkanie na Isilon i skontaktuj się z pomocą techniczną firmy Dell.

Czynności te służą do odtworzenia i przywrócenia komunikacji między systemem Isilon a bramką zabezpieczeń.

Additional Information

Uwaga: Secure Remove Services to EOL. Zapoznaj się z artykułem Zbliża się koniec okresu eksploatacji usług Secure Remote Services (SRS), aby uzyskać informacje na temat niezbędnych aktualizacji.

 

Uwaga: Podsumowując, bramka zabezpieczeń Isilon łączy się z bramką zabezpieczeń za pomocą protokołu REST . Za komunikację z bramką odpowiada pojedynczy węzeł podstawowy. Węzeł ten informuje o docelowym adresie IP dla bramki zabezpieczeń w celu nawiązania połączenia z klastrem.

Jeśli węzeł główny ulegnie awarii, klaster wybiera nowy węzeł podstawowy, a docelowy adres IP jest aktualizowany do bramki zabezpieczeń przy użyciu protokołu REST . Usługi "isi_esrs_d", jak i "isi_rsapi_d" powinny być uruchomione na wszystkich węzłach w klastrze. Podstawowy jest wybierany na podstawie węzłów skonfigurowanych w pulach dostępu bramy.

Podstawowy jest wykrywany przez przejrzenie dzienników lub wydanie poniższego polecenia:
sqlite3 /ifs/.ifsvar/modules/tardis/namespaces/esrs.registered.state.sqlite 'select value from kv_table where key == "esrs_registered_lnn";'
5

W powyższym przykładzie węzłem głównym jest węzeł 5. Po sprawdzeniu adresu IP z puli dostępu bramki dla tego węzła okaże się, że jest to adres IP używany na potrzeby licencji klastra ELM* w bramce zabezpieczeń. Pracownicy Dell Support widzą również ten adres IP w systemach bramki zabezpieczeń ServiceLink używanych do wdzwaniania się w klastry.

Affected Products

PowerScale OneFS

Products

Isilon, PowerScale OneFS
Article Properties
Article Number: 000180903
Article Type: Solution
Last Modified: 26 Nov 2025
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.