Avamar. Сбой рекомендации PDM с ошибкой org.apache.axis2.AxisFault: Розетка закрыта

Summary: Сбой Avamar Proxy Deployment Manager (PDM) с внутренней ошибкой из-за «org.apache.axis2.AxisFault: Socket is closed»

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

В Avamar 19.3 (или более поздней версии) рекомендация PDM завершается сбоем с внутренней ошибкой:

В пользовательском интерфейсе Dell Avamar отображается внутренняя ошибка

На сервере Avamar Server /usr/local/avamar/var/log/vcs/deploymanager.log отображается следующее исключение Java:

2020-12-14T16:21:00.989-0500 TRACE [Pool-6-worker-3][CredentialsMcConnectionFactory#  newMcConnection]: mcUrl:https://127.0.0.1:9443/services/mcsdk20
2020-12-14T16:22:52.543-0500 TRACE [cTaskExecutor-4][CredentialsMcConnectionFactory#  newMcConnection]: client.getServiceStub():com.avamar.mc.sdk20.Mcsdk20Stub@667b1a3c
2020-12-14T16:22:52.544-0500 TRACE [cTaskExecutor-4][CredentialsMcConnectionFactory#  newMcConnection]: user:root
2020-12-14T16:22:52.715-0500 ERROR [cTaskExecutor-4][CredentialsMcConnectionFactory#  newMcConnection]: Error connecting to mc service Exception
org.apache.axis2.AxisFault: Socket is closed
        at org.apache.axis2.AxisFault.makeFault(AxisFault.java:430)
        at org.apache.axis2.transport.http.SOAPMessageFormatter.writeTo(SOAPMessageFormatter.java:83)
        at org.apache.axis2.transport.http.AxisRequestEntity.writeRequest(AxisRequestEntity.java:84)
        at org.apache.commons.httpclient.methods.EntityEnclosingMethod.writeRequestBody(EntityEnclosingMethod.java:499)
        at org.apache.commons.httpclient.HttpMethodBase.writeRequest(HttpMethodBase.java:2114)
        at org.apache.commons.httpclient.HttpMethodBase.execute(HttpMethodBase.java:1096)
        at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:398)
        at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171)
        at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397)
        at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:346)
        at org.apache.axis2.transport.http.AbstractHTTPSender.executeMethod(AbstractHTTPSender.java:557)

Cause

Устройству PDM не удается установить защищенное TLS-подключение к службе MCSDK Avamar, используя IP-адрес замыкания на себя (127.0.0.1). Это соединение не установлено из-за несоответствия сертификатов файла хранилища ключей Tomcat.

Resolution

Инженерный отдел Avamar выясняет основную причину несоответствия сертификатов.

Временное решение.
  1. На сервере Avamar Server выполните следующие команды, чтобы скачать сертификат службы Avamar MCSDK в качестве пользователя root. 
root@ave193:# openssl s_client -connect localhost:9443  -showcerts </dev/null 2>/dev/null   > mcsdk-cert.crt
  1. Установите файл из шага 1 в хранилище ключей Tomcat, используя новый псевдоним kb181136 С помощью следующих команд:

Для Avamar 19.3 и 19.4 выполните следующую команду:

admin@ave193:~/>: keystore_passphrase=$(avlockbox.sh -r keystore_passphrase)

admin@ave193:~/>: keytool -import -file mcsdk-cert.crt -keystore /home/admin/.keystore -alias kb181136 -trustcacerts -noprompt -storepass $keystore_passphrase

В Avamar 19.7 и более поздних версиях файл хранилища ключей Tomcat находится в другом месте. Вместо этого выполните следующую команду:

root@ave197:# keystore_passphrase=$(avlockbox.sh -r keystore_passphrase)

root@ave197:# keytool -import -file mcsdk-cert.crt -keystore /home/tomcat/.keystore -alias kb181136 -trustcacerts -noprompt -storepass $keystore_passphrase

Выходные данные должны выглядеть следующим образом.

Certificate was added to keystore 
  1. Выполните следующие команды очистки:
root@ave193:# rm mcsdk-cert.crt

root@ave193:# unset keystore_passphrase
  1. Выполните еще одну рекомендацию PDM. 

Additional Information

Affected Products

Avamar

Products

Avamar Client for VMware
Article Properties
Article Number: 000181136
Article Type: Solution
Last Modified: 16 Oct 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.