PowerStore: NDU Retry Failed with Out of Space (Dell EMC Correctable)

Summary: NDU failed while attempting to pre-stage the OS image content to the appliance.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

From logs:
Aug 06 08:19:30.528260 FNM12345678901-A cyc_upgrade[58820]: A: Error: # Failed to load docker images from build packages. Skip. Docker images will be downloaded later.
Aug 06 08:19:30.528326 FNM12345678901-A cyc_upgrade[58820]: A: Error: # Output from docker command: Error processing tar file(exit status 1): write /c3aa5bb3809f6e995c327c79018333c282022e0fd53c12685c91acd180c4d0a4/layer.tar: no space left on device
Aug 06 08:19:30.528427 FNM12345678901-A cyc_upgrade[58820]: A: Error: prestage: Failed to prestage dockers

Error screenshot:

Cause

Root filesystem is full.

(Other root partition related KB article : PowerStore Alerts: Platform Root Capacity Alerts )

Resolution

Workaround:
  1. Remove files by connecting with SSH to the appliance with service user and run the following service script: svc_cleanup.
    Instructions how to run the script are available at: Dell EMC PowerStore Service Scripts Guide section Make space on the root partition (svc_cleanup)

    For PowerStore X appliance it is recommended to use the core dump cleanup using the cleanup script to prevent reaching the 80% threshold every day during the daily data collection processing:
      (1)  old data collections
      (2)  journal files
      (3)  one or two old core files.
  2. Retry the NDU.

Affected Products

PowerStore
Article Properties
Article Number: 000181274
Article Type: Solution
Last Modified: 03 Jun 2021
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.