PowerProtect Data Manager: SQL-back-ups mislukken met foutmelding "Kan niet inloggen"
Summary: SQL-back-ups mislukken met de foutmelding 'Kan niet inloggen' vanwege ongeldige PowerProtect-referentiegegevens.
Symptoms
In het deelvenster Taken van PowerProtect Data Manager wordt een kritieke fout weergegeven op het tabblad Bescherming. Bij het analyseren van de details van de fout somt stap 1 het volgende op:
Description The operation failed due to following reason : master, msdb, Matt failed due to error message: Unable to log in. Summary sql.powerprotect.com Failed to perform operation on asset(s) -Matt, msdb, master Reason for restore failure: master, msdb, Matt failed due to error message: Unable to log in.
De PowerProtect /var/log/brs/adm/adm.log Toont:
Line 5851: 2021-01-21T03:08:07.960Z INFO [] [monitorActorSystem-akka.actor.default-dispatcher-13] [][][][][] [c.e.d.e.a.s.s.i.ActivityServiceImpl.completeTask(152)] - Completed task=acc66b7a-127d-4bc1-af65-130e063d1887, result=ActivityResource.Result[status=FAILED,summaries=[sql.powerprotect.com, , Failed to perform operation on asset(s) -master, Matt, msdb, Reason for restore failure: msdb, Matt, master failed due to error message: Unable to log in.
De hostagentservice wordt geregistreerd onder C:\Program Files\DPSAPPS\AgentService\logs Toont:
[2021-01-21 17:53:59,717 GMT| 2021-01-21 09:53:59,717015 Pacific Standard Time| DBGAPPBACKUPASSETS| PID-6452| TID-8940| INFO] nsr/AppAgentService/AddOns/7FFEFD30_C062_4803_BFE7_8A52A9BC4442\AddOnJobManager.py-execute()-Line 323- Process stdout data: {"response":{"jobId":"2339871181","status":"FAILURE","applicationInstances":[{"applicationInstance":"MSSQLSERVER","status":"FAILURE","successfulSources":[],"failedSources":[],"backupCommand":"C:\\Program Files\\DPSAPPS\\MSAPPAGENT\\bin\\ddbmsqlsv.exe -c sql.powerprotect.com -l full -a NSR_DFA_SI_DD_HOST=10.240.194.24 -a NSR_DFA_SI_DEVICE_PATH=/PPDMsql-svcaccout-ppdm-2a284 -a NSR_DFA_SI_DD_USER=PPDMsql-svcaccout-ppdm-2a284 -a JOB_ID=2339871181 -a ENCRYPT_USING_DEFAULT_VALUES=FALSE -a BACKUP_PROMOTION=ALL -y +2d -I C:\\Program Files\\DPSAPPS\\MSAPPAGENT\\tmp\\Ddb80CF.tmp MSSQL:","output":""}]},"errors":[{"type":"systemErr","text":"Unable to log in.\n"}]}
Cause
PowerProtect aanmeldingsgegevens die zijn gemaakt bevatten een ongeldige gebruikersnaam of wachtwoord. Bij het maken van PowerProtect referenties wordt geen verificatiecontrole uitgevoerd, dus het probleem wordt pas ervaren als er een verificatie plaatsvindt. Gebruikersnamen kunnen worden vermeld in de indeling "domein\gebruikersnaam" of "username@domain.suffix". Het domeinachtervoegsel (.org, .com, .edu) MOET worden opgegeven bij gebruik van username@domain indeling.
Voorbeelden van geldige gebruikersnamen:
administrator@my-domain.com my-domain\administrator
Voorbeelden van ongeldige gebruikersnamen:
administrator@my-domain administrator
Resolution
Werk PowerProtect-referenties bij zodat deze de juiste indeling van de gebruikersnaam en het juiste wachtwoord bevatten.
- Klik in PowerProtect op >Administration Credentials.
- Selecteer de referentie en klik op Bewerken.
- Voer de juiste gebruikersnaam en het juiste wachtwoord in.
- Klik op Opslaan.