SourceOne Email Supervisor kan ikke cachelagre store meddelelser
Summary: SourceOne Email Supervisor kan ikke cachelagre store meddelelser og logger en timeoutfejl "The request channel timed out while waiting for a reply after 00:04:59.1719158"
Symptoms
Når SourceOne Email Supervisor støder på store meddelelser og forsøger at cache meddelelserne fra SourceOne Email Management, får den timeout efter 5 minutter.
Tjenesten E-mailcachelagring mislykkes, og følgende logføres i hændelseslogfilerne for Mail Supervisor:
Log Name: Email Supervisor Source: Email Supervisor Date: 12/16/2020 5:52:41 AM Event ID: 59 Task Category: Email Caching Level: Error Keywords: Classic User: N/A Computer: <Supervisor Server Name> Description: An error occurred while trying to download a message from Email Archive Server. Details = Server: <SourceOne Server>, EntryID: <MsgID>, Description: The request channel timed out while waiting for a reply after 00:04:59.3280745. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout.
Cause
Dette er en kendt fejl, der er beskrevet i SDR 63239.
Resolution
Dette problem løses i programrettelser eller Service Pack-versioner af SourceOne Email Supervisor 7.2 SP1 Hotfix 63239.
EMC SourceOne-programrettelse og Service Pack-sæt kan downloades over https://dell.com/support.
Med hotfixet kan timeoutværdien nu konfigureres. Værdierne kan konfigureres ved at indstille følgende registreringsdatabasenøgler på SourceOne Email Supervisor-serveren:
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\EMC\SourceOne\Email Supervisor
Key Name: DocManagementSvcClientOpenTimeout Key Value: 15 (Decimal - Minutes) Key Type: REG_DWORD Key Name: DocManagementSvcClientSendTimeout Key Value: 15 (Decimal - Minutes) Key Type: REG_DWORD Key Name: DocManagementSvcClientReceiveTimeout Key Name: 15 (Decimal - Minutes) Key Type: REG_DWORD