NMDA:無法在 NMC 中建立 NMDA Oracle 用戶端備份組態。Oracle 用戶端備份組態失敗,並傳回錯誤:The NMC server could not obtain the required memory for the requested operation. the gst log provides the detail

Summary: 無法在 NMC 中建立 NMDA Oracle 用戶端備份組態。Oracle 用戶端備份組態失敗,並傳回錯誤:The NMC server could not obtain the required memory for the requested operation. the gst log provides the detail

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Symptoms

無法在 NMC
上建立新的 NMDA 用戶端。建立期間出現錯誤:NMC server could not obtain the required memory for the requested operation.
The gstd log provides details

Cause

1.在 64 位元 OS 上安裝了 NMDA 32 位元軟體
2.Oracle 遠端代理程式使用二進位轉換名稱註冊 (可能發生在一些使用二進位名稱註冊代理程式的狀況,轉換後的名稱:nsrorara.bin,或使用封裝指令檔,因為它會在內部執行二進位轉換)。

Resolution

在 Oracle 用戶端主機上,執行下列步驟:- 
  1. nsradmin -p nsrexecd
  2. p type : nsr remote agent ; backup type : oracle
    1. 輸出將顯示:-
    2. remote agent executable: nsrorara.bin;  => 輸出顯示 nsrorara.bin
  3. 接著取消註冊 NMDA 代理程式:
    1. /usr/bin/nsrorara.bin -u
  4. 然後使用正確的二進位名稱註冊:
    1. 將官方的二進位 /usr/bin/nsrorara 重新命名為 /usr/bin/nsrorara.bin
      1. cd /usr/bin
      2. mv nsrorara nsrorara.bin
    2. 在 /usr/bin 下建立名為 nsrorara 的指令檔檔案:
      1. vi nsrorara
      2. 將以下內容放入新建立的指令檔檔案 nsrorara 內:
        1. #! /bin/shLIBPATH=/oracle/121020/lib
        2. export LIBPATH
        3. exec /usr/bin/nsrorara.bin "$@"
      3. 儲存檔案和 cat nsrorara 到 /usr/bin 下 (確認已正確輸入上述內容)。
      4. chmod 0755 nsrorara
      5. /usr/bin/nsrorara -i
  5. 然後執行 NMC 用戶端組態精靈,以建立新的 NMDA 用戶端。
  6. 執行新的 NMDA 用戶端組態後,重新命名這些檔案以重設原始檔案:
    1. mv /usr/bin/nsrorara  /usr/bin/nsrorara.sh
    2. mv /usr/bin/nsrorara.bin  /usr/bin/nsrorara
  7. nsradmin -p nsrexecd
    1. p type : nsr remote agent ; backup type : oracle
    2. remote agent executable: nsrorara;  => 輸出顯示回到 nsrorara

Products

NetWorker Family
Article Properties
Article Number: 000183208
Article Type: Solution
Last Modified: 23 Aug 2022
Version:  5
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