Data Protection Advisor (DPA): El agente de DPA no se pudo registrar en el servidor de aplicaciones con el error exception.name_conflict

Summary: El agente de DPA no se registra en el servidor de aplicaciones con el error exception.name_conflict

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Symptoms

El agente de DPA instalado nuevo no se puede registrar en el servidor de aplicaciones de DPA. En dpaagent. log, el siguiente error indica que el registro falla debido a un conflicto de nombre:      
< error >
< id > Exception.name_conflict </ID > <
mensaje > ya existe un alias con el mismo nombre. Seleccione otro nombre </Message >
< Entry name = "type" > alias </entry >
</error >
Err 18330,18330 20210304:210609 Agent. config-initAgentConfig (): No se pudo registrar el agente con el servidor. En espera de reintento...

Sin embargo, el error anterior no proporciona el nombre de conflicto exacto, aun cuando el nivel de depuración del agente está habilitado.

Cause

La falla de registro del agente se debe a un conflicto de nombre como se muestra en el registro de dpaagent. Una vez que se elimina el hostname que causa el conflicto, el agente puede registrarse correctamente con el servidor de aplicaciones de DPA.

Resolution

El nombre de conflicto no se encuentra en el registro de dpaagent, ni siquiera con depuración de nivel bajo habilitado, ya que el servidor de aplicaciones de DPA rastrea esta información. Para determinar el nombre del conflicto y resolver el problema, siga los pasos que se indican a continuación:      
  1. Acceda al servidor de aplicaciones de DPA y navegue a Server. log en < DPA install dir >/Services/logs/.
  2. En el archivo Server. log, busque la palabra clave "node not found". Se debe ver algo similar al siguiente:      
2021-03-05 09:54:53114 ERROR [com. EMC. Apollo. Command. node. UpdateNodeCommandBean] (http-/0.0.0.0:9002-3) el nodo ya se encontró usando un nuevo alias XXXXXX Existing nodeElement Name: YYYYYY
09:54:53114 error [org. JBoss. as. EJB3] (http-/0.0.0.0:9002-3) javax. EJB. EJBTransactionRolledbackException: Ya existe un alias con el mismo nombre. Seleccione otro nombre (exception.name_conflict)
  1. Consulte DPA GUI > Inventory > Biblioteca de objetos > pestaña hosts y busque host YYYYYY.
  2. Seleccione host YYYYYY Properties (propiedades) > sección alias y busque el nombre de conflicto XXXXXX.
  3. Haga una copia de todos los nombres de alias en caso de que se produzca un problema.
  4. Seleccione nombre de alias XXXXXX y haga clic en eliminar.
  5. Haga clic en Aplicar y luego haga clic en Aceptar.
  6. Reinicie el agente de DPA que no se pudo registrar y debe poder registrarse en el servidor de aplicaciones de DPA.
Si el agente continúa fallando, revise un registro de agente actualizado como un error diferente o es posible que se produzca un problema. Es posible que haya un error de conflicto de nombre adicional que se debe resolver mediante los pasos anteriores.

Póngase en contacto con el equipo de soporte técnico Dell EMC para obtener más información.

Affected Products

Data Protection Advisor
Article Properties
Article Number: 000183846
Article Type: Solution
Last Modified: 23 Jul 2021
Version:  4
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