IDPA-haku: Virhe raportoitu testattaessa yhteyttä ulkoiseen identiteetintarjoajaan

Summary: Tässä tietämyskannan artikkelissa kuvataan ongelma, jossa Test Connection -painike ilmoittaa virheilmoituksesta, joka johtuu sidonnan epäonnistumisesta secure socket layerin avulla.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerProtect DPSearchin hallintakonsolin LDAP-asetukset-osassa ilmoitetaan virheestä, kun Testaa yhteys -painiketta käytetään. Virhesanomaa ei näytetä, jos SSL (Secure Socket Layer)-kentän arvo on false.


Seuraavankaltaiset virheilmoitukset löytyvät cis.log tiedostosta, joka sijaitsee /usr/local/search/log/cis-kansiossa :

P7FF0|2021/03/09 13:34:46:765|DEBUG|cislockbox.rb(62)|Parsed body A-OK 
P7FF0|2021/03/09 13:34:46:765|DEBUG|cislockbox.rb(79)|Binding to ldap using: [Server=ldaphost, Port:636, User=ldapuser, Pwd: ********************] 
P7FF0|2021/03/09 13:34:46:768|DEBUG|cisconfigldap.rb(128)|Binding to [ldaphost:636 as ldapuser] 
P7FF0|2021/03/09 13:34:46:780|DEBUG|ldap_internal.rb(645)|Ldap Internal; bind_as: "Connection to ldap server ldaphost failed, ex: SSL_connect returned=1 errno=0 state=error: certificate verify failed." 
P7FF0|2021/03/09 13:34:46:780|DEBUG|ldap_internal.rb(645)|Ldap Internal; bind_as: "bind as result: " 
P7FF0|2021/03/09 13:34:46:780|DEBUG|ldap_provider.rb(317)|Ldap Provider; validate_user: "bind_as user ldapuser failed on LDAP Host ldaphost with #\u003cOpenStruct code=0, message=\"Success\"\u003e" 
P7FF0|2021/03/09 13:34:46:780|DEBUG|ldap_provider.rb(317)|Ldap Provider; validate_user: "validate_user failed. User entry: null" 
P7FF0|2021/03/09 13:34:46:781|ERROR|cisconfigldap.rb(141)|LDAP binding failed. 
P7FF0|2021/03/09 13:34:46:781|ERROR|cislockbox.rb(99)|PUT /cis/lockbox/ldap/_test : LDAP binding failed.  Invalid LDAP parameters.  

DPSearch-isännässä, jos ldapsearch Komentoa suoritetaan "-v" ja "-d1" kytkimiä, seuraavanlaisia tietoja löytyy:  

TLS trace: SSL_connect:before/connect initialization
TLS trace: SSL_connect:SSLv2/v3 write client hello A
TLS trace: SSL_connect:unknown state
TLS certificate verification: depth: 1, err: 20, subject <subject of certificate>, issuer: <issuer details>
TLS certificate verification: Error, unable to get local issuer certificate
TLS trace: SSL3 alert write:fatal:unknown CA
TLS trace: SSL_connect:error in error
TLS trace: SSL_connect:error in error
TLS: cann't connect: error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed (unable to get local issuer certificate).
ldap_err2string
ldap_sasl_bind(SIMPLE): Can't contact LDAP server(-1)


 

Cause

Root Certification Authority- (rootCA) ja keskitason CA-varmenteet (jos käytössä) eivät ole luotetussa varmennesäilössä, mikä aiheuttaa varmenteen vahvistusvirheen.

Resolution

Ongelman ratkaisuvaiheet:

  1. Hanki kopio rootCA:sta ja keskitason varmentajasta (jos käytössä) PEM (Privacy-Enhanced Mail) -muodossa.
  2. Kopioi PEM-tiedostot vaiheesta 1 kansioon /etc/pki/trust/anchors /.
  3. Kun olet kirjautuneena root-tilinä, suorita seuraava komento:
update-ca-certificates


 

Additional Information

Seuraavat vaiheet rootCA-varmenteen viemiseksi Microsoft Windows -varmenteen myöntäjältä:
 

  1. Kirjaudu varmenteen myöntäjän pääpalvelimeen järjestelmänvalvojan tilillä.
  2. Siirry aloitusnäyttöön, valitse Suorita, kirjoita cmd ja valitse OK.
  3. Voit viedä päävarmenteiden myöntäjän palvelimen uuteen tiedostonimeen suorittamalla seuraavan komennon:
certutil -ca.cert ca_name.cer
  1. Kopioi varmenne DPSearch-palvelimeen.
  2. Siirry kansioon, johon varmennetiedosto kopioitiin edellä vaiheessa 4, ja muunna varmenne PEM-muotoon suorittamalla openSSL-komento: 
    # openssl x509 -in ca_ name.cer -inform der -out ca_name.pem -outform pem
  3. ca_name.PEM-tiedosto on valmis käytettäväksi yllä olevassa Ratkaisu-osassa mainittuihin vaiheisiin.


Korvaa yllä olevissa vaiheissa ca_name nimellä, joka helpottaa isäntänimen tunnistamista.

Affected Products

Data Protection Search, Data Protection Search, PowerProtect Data Protection Software, Integrated Data Protection Appliance Software
Article Properties
Article Number: 000184001
Article Type: Solution
Last Modified: 22 Aug 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.