IDPA: ACM UI의 백업 서버 대시보드에서 "Backup Server viewuser user password is out of sync. Please update the latest password" 오류가 나타남
Summary: 이 문서에서는 Avamar/백업 서버에서 viewuser 사용자 암호가 변경되지 않았지만 ACM UI의 백업 서버 대시보드에서 "Backup Server viewuser user password is out of sync. Please update the latest password" 오류가 나타나는 경우를 다룹니다. 이 문제는 어플라이언스가 코드 업그레이드를 진행 중인 경우에 나타날 수 있습니다. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
ACM UI의 백업 서버 대시보드에서 "Backup Server viewuser user password is out of sync. 백업 서버 대시보드에서 최신 암호를 업데이트하십시오.
사용자가 동기화되지 않는 암호 팝업을 클릭하고 암호를 업데이트하려고 하면 UI에 "Avamar viewuser 사용자 테스트 연결 실패"라는 오류가 표시됩니다.
SSH를 'root' 사용자로 열고 다음 명령을 실행하여 ACM이 MCSDK를 사용하여 Avamar 또는 Backup Server Postgres Database에 로그인할 수 없는 MCSDK 호환성으로 인해 이 문제가 발생하는지 확인합니다.
예:
위의 명령은 ACM과 Avamar/Backup Server MCSDK 간의 호환성 문제를 가리킵니다. ACM이 Avamar Server의 Postgres Database에 로그인하여 viewuser 암호 상태를 가져올 수 없기 때문입니다.
Avamar 또는 백업 서버에 대한 SSH를 열고 수동 로그인 시도 시 viewuser 암호가 작동하는지 확인합니다.
올바른 암호를 확인했으면 password viewuser user password out of sync 팝업을 클릭하고 이 암호의 업데이트를 시도합니다. Test connection failure가 표시되면 Resolution 섹션으로 진행합니다.
사용자가 동기화되지 않는 암호 팝업을 클릭하고 암호를 업데이트하려고 하면 UI에 "Avamar viewuser 사용자 테스트 연결 실패"라는 오류가 표시됩니다.
SSH를 'root' 사용자로 열고 다음 명령을 실행하여 ACM이 MCSDK를 사용하여 Avamar 또는 Backup Server Postgres Database에 로그인할 수 없는 MCSDK 호환성으로 인해 이 문제가 발생하는지 확인합니다.
grep -i "SQLException.*viewuser.*authentication.*not supported" -A2 /usr/local/dataprotection/var/configmgr/server_data/logs/server.log
예:
2021-03-30 10:45:25,304 INFO [https-jsse-nio-8543-exec-10]-restadapter.LoginService: Test connection failed for Avamar server viewuser 2021-03-30 10:49:08,451 ERROR [Thread-379779]-avadapter.AvamarUtil: SQLException while checking viewuser connection: org.postgresql.util.PSQLException: The authentication type 10 is not supported. Check that you have configured the pg_hba.conf file to include the client's IP address or subnet, and that it is using an authentication scheme supported by the driver. 2021-03-30 10:57:57,402 ERROR [https-jsse-nio-8543-exec-10]-avadapter.AvamarUtil: SQLException while checking viewuser connection: org.postgresql.util.PSQLException: The authentication type 10 is not supported. Check that you have configured the pg_hba.conf file to include the client's IP address or subnet, and that it is using an authentication scheme supported by the driver.
위의 명령은 ACM과 Avamar/Backup Server MCSDK 간의 호환성 문제를 가리킵니다. ACM이 Avamar Server의 Postgres Database에 로그인하여 viewuser 암호 상태를 가져올 수 없기 때문입니다.
Avamar 또는 백업 서버에 대한 SSH를 열고 수동 로그인 시도 시 viewuser 암호가 작동하는지 확인합니다.
- 다음 명령을 사용하여 viewuser 사용자 로그인이 작동하는지 확인합니다.
-
psql -p 5555 mcdb -U viewuser -h
-
올바른 암호를 확인했으면 password viewuser user password out of sync 팝업을 클릭하고 이 암호의 업데이트를 시도합니다. Test connection failure가 표시되면 Resolution 섹션으로 진행합니다.
Cause
ACM과 Avamar 또는 백업 서버 간의 호환성 문제가 있습니다. 이 문제는 Avamar가 상위 버전으로 업그레이드되었지만 ACM이 아직 업그레이드되지 않은 경우에 발생할 수 있습니다. 예를 들어 IDPA DP8X 모델의 경우 Avamar는 IDPA 업그레이드 워크플로의 일부가 아니며 별도 워크플로의 일부로 업그레이드됩니다.
IDPA DP8X 업그레이드에 대한 권장 사항:
IDPA DP8X 업그레이드에 대한 권장 사항:
- ACM의 IDPA 업그레이드 워크플로를 먼저 시작해야 합니다.
- IDPA 업그레이드 워크플로가 ESXi 업그레이드 단계에 도달하면 이러한 호환성 문제를 방지하기 위해 Avamar 업그레이드를 시작할 수 있습니다.
Resolution
1. SSH를 Avamar Server/Backup Server에 'admin user'로 열고 다음 세부 정보를 확인합니다.
2. SSH를 ACM에 'root' 사용자로 열고 IDPA 버전을 확인합니다.
3. 아래 스택 테이블 공급업체에 따라 ACM 버전이 해당 Avamar 버전과 일치하는지 확인합니다.
참고: 1단계와 2단계에서 확인한 ACM 및 Avamar 버전이 위의 표와 일치하지 않으면 호환성 문제가 설명될 수 있습니다.
4. IDPA 또는 Avamar의 나머지 버전을 IDPA 스택 버전과 일치하도록 업그레이드합니다. 업그레이드가 진행 중인 DP8X 어플라이언스인 경우 이 오류가 예상되며 업그레이드 프로세스가 완전히 완료될 때까지 기다립니다.
mcserver.sh --version
2. SSH를 ACM에 'root' 사용자로 열고 IDPA 버전을 확인합니다.
rpm -qa | grep -i dataprotection
3. 아래 스택 테이블 공급업체에 따라 ACM 버전이 해당 Avamar 버전과 일치하는지 확인합니다.
| IDPA 버전(ACM 버전) | Avamar 또는 백업 서버 버전 |
| 2.2 | 7.5.1.101 |
| 2.3.x | 18.2.0.134 |
| 2.4.x | 18.2.0.134 |
| 2,5 | 19.1.0.38 |
| 2.6.x | 19.3.0.149 |
참고: 1단계와 2단계에서 확인한 ACM 및 Avamar 버전이 위의 표와 일치하지 않으면 호환성 문제가 설명될 수 있습니다.
4. IDPA 또는 Avamar의 나머지 버전을 IDPA 스택 버전과 일치하도록 업그레이드합니다. 업그레이드가 진행 중인 DP8X 어플라이언스인 경우 이 오류가 예상되며 업그레이드 프로세스가 완전히 완료될 때까지 기다립니다.
Affected Products
Integrated Data Protection Appliance FamilyProducts
PowerProtect DP8300, PowerProtect DP8800, PowerProtect Data Protection Software, PowerProtect Data Protection Hardware, PowerProtect DP8400, PowerProtect DP8900Article Properties
Article Number: 000185598
Article Type: Solution
Last Modified: 01 Sept 2023
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.