IDPA: ACM kullanıcı arayüzünde "Backup Server viewuser kullanıcı parolası eşit değil. Lütfen Backup Server Dashboard'da (Yedekleme Sunucusu Panosu) en son parolayı güncelleştirin"
Summary: Bu makalede Avamar/Backup Server'da viewuser kullanıcı parolasının değişmediği ancak ACM kullanıcı arayüzünde "Backup Server viewuser kullanıcı parolası eşit değil" hatasının görüntülenmesi sorunu açıklanmaktadır. Lütfen Backup Server Dashboard'da (Yedekleme Sunucusu Panosu) en son parolayı güncelleştirin. Bu sorun, bir cihazın Kod Yükseltme işlemi sırasında görülebilir. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
ACM kullanıcı arayüzünde "Backup Server viewuser kullanıcı parolası eşit değil. Lütfen Backup Server Dashboard'da (Yedekleme Sunucusu Panosu) en son parolayı güncelleştirin.
Kullanıcı, senkronizasyon dışı parola açılır penceresine tıkladığında ve parolayı güncellemeye çalıştığında, kullanıcı arayüzünde "Avamar viewuser user test connection failed" (Avamar viewuser kullanıcı test bağlantısı başarısız oldu) hatası görüntüleniyor:
SSH'yi ACM'yi "root" kullanıcısı olarak açın ve bu sorunun MCSDK uyumluluğundan kaynaklanmadığında ACM'nin Avamar'da veya Backup Server Postgres Database'de MCSDK kullanarak oturum açamayabileceğini onaylamak için aşağıdaki komutu çalıştırın:
Örnek:
Yukarıdaki komut, ACM'nin Avamar Sunucusunda Postgres Veritabanı'da oturum açarak viewuser parola durumunu getiremediği için ACM ve Avamar/Backup Server MCSDK arasındaki uyumluluk sorununa yer verilmiştir.
Avamar veya Yedekleme Sunucusunda SSH oturumu açın ve viewuser parolasının manuel oturum açma girişiminde çalışıp çalışmadığını doğrulayın.
Doğru parolayı belirledikten sonra, password (parola) viewuser user password out of sync (viewuser kullanıcı parolası senkronize değil) açılır penceresini tıklayın ve bu şifreyi güncelleştirmeyi deneyin. Test bağlantısı hatası görürseniz çözüm bölümüne ilerleyin.
Kullanıcı, senkronizasyon dışı parola açılır penceresine tıkladığında ve parolayı güncellemeye çalıştığında, kullanıcı arayüzünde "Avamar viewuser user test connection failed" (Avamar viewuser kullanıcı test bağlantısı başarısız oldu) hatası görüntüleniyor:
SSH'yi ACM'yi "root" kullanıcısı olarak açın ve bu sorunun MCSDK uyumluluğundan kaynaklanmadığında ACM'nin Avamar'da veya Backup Server Postgres Database'de MCSDK kullanarak oturum açamayabileceğini onaylamak için aşağıdaki komutu çalıştırın:
grep -i "SQLException.*viewuser.*authentication.*not supported" -A2 /usr/local/dataprotection/var/configmgr/server_data/logs/server.log
Örnek:
2021-03-30 10:45:25,304 INFO [https-jsse-nio-8543-exec-10]-restadapter.LoginService: Test connection failed for Avamar server viewuser 2021-03-30 10:49:08,451 ERROR [Thread-379779]-avadapter.AvamarUtil: SQLException while checking viewuser connection: org.postgresql.util.PSQLException: The authentication type 10 is not supported. Check that you have configured the pg_hba.conf file to include the client's IP address or subnet, and that it is using an authentication scheme supported by the driver. 2021-03-30 10:57:57,402 ERROR [https-jsse-nio-8543-exec-10]-avadapter.AvamarUtil: SQLException while checking viewuser connection: org.postgresql.util.PSQLException: The authentication type 10 is not supported. Check that you have configured the pg_hba.conf file to include the client's IP address or subnet, and that it is using an authentication scheme supported by the driver.
Yukarıdaki komut, ACM'nin Avamar Sunucusunda Postgres Veritabanı'da oturum açarak viewuser parola durumunu getiremediği için ACM ve Avamar/Backup Server MCSDK arasındaki uyumluluk sorununa yer verilmiştir.
Avamar veya Yedekleme Sunucusunda SSH oturumu açın ve viewuser parolasının manuel oturum açma girişiminde çalışıp çalışmadığını doğrulayın.
- Aşağıdaki komutu kullanarak viewuser kullanıcısı girişinin çalıştığını doğrulayın:
-
psql -p 5555 mcdb -U viewuser -h
-
Doğru parolayı belirledikten sonra, password (parola) viewuser user password out of sync (viewuser kullanıcı parolası senkronize değil) açılır penceresini tıklayın ve bu şifreyi güncelleştirmeyi deneyin. Test bağlantısı hatası görürseniz çözüm bölümüne ilerleyin.
Cause
ACM ile Avamar veya Yedekleme Sunucusu arasındaki uyumluluk sorunu. Avamar daha yüksek sürüme yükseltildiyse ancak ACM henüz yükseltilmemişse bu sorun meydana gelebilir. Örneğin IDPA DP8X modellerinde Avamar, IDPA Yükseltme iş akışının bir parçası değildir ve ayrı bir iş akışının parçası olarak yükseltilir.
IDPA DP8X Yükseltmeleri için Öneri:
IDPA DP8X Yükseltmeleri için Öneri:
- Önce ACM'den IDPA Yükseltme iş akışı başlatılmalıdır.
- IDPA Yükseltme iş akışı ESXi yükseltme aşamasına ulaştığında bu tür uyumluluk sorunlarından kaçınmak için Avamar yükseltmesi başlatılabilir.
Resolution
1. SSH'yi Avamar Server/Backup Server'a "admin user" (yönetici kullanıcı) olarak açın ve aşağıdaki ayrıntıları doğrulayın:
2. SSH'yi ACM'ye "root" kullanıcısı olarak açın ve IDPA sürümünü doğrulayın:
3. ACM sürümünün aşağıdaki yığın tablosu sağlayıcısına göre ilgili Avamar sürümüyle eşleştiğini doğrulayın:
Not: 1. ve 2. Adımda belirtilen ACM ve Avamar sürümleri yukarıdaki tabloyla eşleşmiyorsa bu durum uyumluluk sorununun sebebini açıklar.
4. IDPA Yığını sürümleriyle eşleşmesi için IDPA veya Avamar'ın geri kalan kısmını yükseltin. Bu, yükseltme işleminin ortasında olan bir DP8X cihazıysa bu beklenen bir hatadır. Yükseltme işleminin sonuna tamamen bitmesini bekleyin.
mcserver.sh --version
2. SSH'yi ACM'ye "root" kullanıcısı olarak açın ve IDPA sürümünü doğrulayın:
rpm -qa | grep -i dataprotection
3. ACM sürümünün aşağıdaki yığın tablosu sağlayıcısına göre ilgili Avamar sürümüyle eşleştiğini doğrulayın:
| IDPA Sürümü (ACM Sürümü) | Avamar veya Yedekleme Sunucusu Sürümü |
| 2.2 | 7.5.1.101 |
| 2.3.x | 18.2.0.134 |
| 2.4.x | 18.2.0.134 |
| 2.5 | 19.1.0.38 |
| 2.6.x | 19.3.0.149 |
Not: 1. ve 2. Adımda belirtilen ACM ve Avamar sürümleri yukarıdaki tabloyla eşleşmiyorsa bu durum uyumluluk sorununun sebebini açıklar.
4. IDPA Yığını sürümleriyle eşleşmesi için IDPA veya Avamar'ın geri kalan kısmını yükseltin. Bu, yükseltme işleminin ortasında olan bir DP8X cihazıysa bu beklenen bir hatadır. Yükseltme işleminin sonuna tamamen bitmesini bekleyin.
Affected Products
Integrated Data Protection Appliance FamilyProducts
PowerProtect DP8300, PowerProtect DP8800, PowerProtect Data Protection Software, PowerProtect Data Protection Hardware, PowerProtect DP8400, PowerProtect DP8900Article Properties
Article Number: 000185598
Article Type: Solution
Last Modified: 01 Sept 2023
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.