IDPA: Får ikke tilgang til ACM-oppgraderingsgrensesnittet på grunn av validering av oppgradering med meldingen 'omadressering mislyktes'

Summary: Denne artikkelen veileder deg gjennom et scenario under valideringsprosessen for IDPA-oppgraderingen der omadresseringen av ACM-oppgraderingsgrensesnittet mislykkes. Dette kan skje hvis port 9443 er blokkert i nettverksbrannmuren mellom systemet som kobler til ACM og ACM. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Kontroller at utpakkingen av oppgraderingsbinærfilen på ACM var vellykket.

Logg på ACM med PuTTY eller SSH som root-bruker, og kjør følgende kommando:

cat /data01/tmp/patch/logs/extract.log

05/01/21 06:43:33 ************ Executing extract.sh ************

05/01/21 06:43:34 Dataprotection upgrade rpm not found.

05/01/21 06:43:34 Deploying dataprotection-upgrade binary in tomcat.

05/01/21 06:44:08 Checking for the mandatory files in tar

05/01/21 06:44:08 Creating second instance of tomcat

05/01/21 06:44:41 Successfully created second tomcat instance

Kontroller at den andre oppgraderingen av Tomcat-prosessen var vellykket:

tail -5 /data01/tmp/patch/logs/tomcat_creation.log

05/01/21 06:44:41 Upgrade war exists in old tomcat. Removing war

05/01/21 06:44:41 Successfully deleted dataprotection upgrade war from old tomcat

05/01/21 06:44:41 Dataprotection upgrade directory exists in old tomcat. Removing war

05/01/21 06:44:41 Successfully deleted dataprotection upgrade directory from old tomcat

05/01/21 06:44:41 Successfully created second tomcat instance

Kontroller at ACM lytter på port 9443 ved hjelp av følgende kommando:

netstat -apn |grep 9443

Kontroller at oppgraderingstjenesten er oppe og kjører ved hjelp av følgende kommando:

service dataprotection_webapp_upgrade status

dataprotection_webapp_upgrade.service - SYSV: Apache Tomcat init script

   Loaded: loaded (/etc/init.d/dataprotection_webapp_upgrade)

   Active: active (exited) since Sat 2021-05-01 06:44:12 PDT; 4 days ago

  Process: 17035 ExecStart=/etc/init.d/dataprotection_webapp_upgrade start (code=exited, status=0/SUCCESS)

I et annet brukstilfelle ble følgende meldinger notert på ACM upgrade-utility.log:

grep -i "java.net.ConnectException" /data01/tmp/patch/logs/upgrade-utility.log

2020-10-16 10:59:41,576 ERROR [https-jsse-nio-8543-exec-8]-util.RestUtil: Error occured while executing REST request. due to java.net.ConnectException: Connection timed out (Connection timed out)

Kontroller at port 9443 er åpen i nettverksbrannmuren mellom systemet som kobler til ACM og selve ACM.

Cause

Port 9443 ble blokkert i nettverksbrannmuren mellom systemet som har tilgang til ACM og ACM, noe som forårsaket dette problemet.

Resolution

Merk: Informasjonen i goidpa tool kan gi mer informasjon om dette problemet. Følg artikkelen nedenfor for å installere goidpa tool: Tilpasset verktøy for PowerProtect-databeskyttelse: GoIDPA-verktøy

Kjør følgende kommando på ACM:
./goidpa system upgrade-port-check

Dette gjør at du kan teste om port 9443 kan nås fra systemet.


Reparasjon:

Port 9443 må åpnes i nettverksbrannmuren mellom systemet Tilgang til ACM-grensesnittet og ACM VM. 


Omgåelse av problemet:

Det kan være mulig å opprette en tunnel på PuTTY for å utføre viderekobling av porter som en midlertidig løsning.

  1. Høyreklikk PuTTY og gå til Connection >SSH >Tunnels
  2. Skriv inn detaljene i følgende format:
Source Port 443

Destination IP: ACM Public IP Address

Destination Port: 443
  1. Klikk på Add (Legg til)
  2. Legg til den andre havnetunnelen for 9443 i henhold til detaljene nedenfor, og klikk på Legg til
Source Port 9443

Destination IP: ACM Public IP Address

Destination Port: 9443

PUTTY-skjermbilde som viser tunnelkonfigurasjon.  

  1. Åpne brukergrensesnittet for IDPA-oppgradering på følgende URL-adresse:
https://localhost:9443/dataprotection-upgrade

Affected Products

Integrated Data Protection Appliance Family
Article Properties
Article Number: 000186345
Article Type: Solution
Last Modified: 30 May 2025
Version:  9
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.