IDPA: Nie można uzyskać dostępu do interfejsu aktualizacji ACM z powodu weryfikacji aktualizacji z komunikatem "przekierowanie nie powiodło się"

Summary: Ten artykuł przeprowadzi Cię przez scenariusz podczas procesu weryfikacji uaktualnienia IDPA, w którym przekierowanie interfejsu użytkownika aktualizacji ACM kończy się niepowodzeniem. Może się to zdarzyć, jeśli port 9443 jest zablokowany w zaporze sieciowej między systemem uzyskującym dostęp do ACM a ACM. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Sprawdź, czy wyodrębnienie pliku binarnego aktualizacji w ACM powiodło się.

Zaloguj się do ACM za pomocą PuTTY lub SSH jako użytkownik root i uruchom następujące polecenie:

cat /data01/tmp/patch/logs/extract.log

05/01/21 06:43:33 ************ Executing extract.sh ************

05/01/21 06:43:34 Dataprotection upgrade rpm not found.

05/01/21 06:43:34 Deploying dataprotection-upgrade binary in tomcat.

05/01/21 06:44:08 Checking for the mandatory files in tar

05/01/21 06:44:08 Creating second instance of tomcat

05/01/21 06:44:41 Successfully created second tomcat instance

Sprawdź, czy tworzenie procesu drugiego uaktualnienia serwera Tomcat zakończyło się pomyślnie:

tail -5 /data01/tmp/patch/logs/tomcat_creation.log

05/01/21 06:44:41 Upgrade war exists in old tomcat. Removing war

05/01/21 06:44:41 Successfully deleted dataprotection upgrade war from old tomcat

05/01/21 06:44:41 Dataprotection upgrade directory exists in old tomcat. Removing war

05/01/21 06:44:41 Successfully deleted dataprotection upgrade directory from old tomcat

05/01/21 06:44:41 Successfully created second tomcat instance

Sprawdź, czy ACM nasłuchuje na porcie 9443, używając następującego polecenia:

netstat -apn |grep 9443

Sprawdź, czy usługa uaktualnienia jest uruchomiona, używając następującego polecenia:

service dataprotection_webapp_upgrade status

dataprotection_webapp_upgrade.service - SYSV: Apache Tomcat init script

   Loaded: loaded (/etc/init.d/dataprotection_webapp_upgrade)

   Active: active (exited) since Sat 2021-05-01 06:44:12 PDT; 4 days ago

  Process: 17035 ExecStart=/etc/init.d/dataprotection_webapp_upgrade start (code=exited, status=0/SUCCESS)

W innym przypadku użycia zanotowano następujące komunikaty ACM upgrade-utility.log:

grep -i "java.net.ConnectException" /data01/tmp/patch/logs/upgrade-utility.log

2020-10-16 10:59:41,576 ERROR [https-jsse-nio-8543-exec-8]-util.RestUtil: Error occured while executing REST request. due to java.net.ConnectException: Connection timed out (Connection timed out)

Sprawdź, czy na zaporze sieciowej między systemem uzyskującym dostęp do ACM a samym ACM jest otwarty port 9443.

Cause

Port 9443 został zablokowany w zaporze sieciowej między systemem uzyskującym dostęp do ACM a ACM, powodując ten problem.

Resolution

Uwaga: Plik goidpa tool może udzielić więcej informacji na temat tego problemu. Postępuj zgodnie z poniższym artykułem, aby zainstalować goidpa tool: Urządzenie PowerProtect Data Protection: Narzędzie GoIDPA

Uruchom następujące polecenie w ACM:
./goidpa system upgrade-port-check

Umożliwia to sprawdzenie, czy port 9443 jest osiągalny z systemu.


Rozwiązanie:

Należy otworzyć port 9443 w zaporze sieciowej między systemem uzyskującym dostęp do interfejsu użytkownika ACM a maszyną wirtualną ACM. 


Obejście problemu:

W celu obejścia problemu może być możliwe utworzenie tunelu w programie PuTTY w celu przekierowania portów.

  1. Kliknij prawym przyciskiem myszy PuTTY i przejdź do Connection >SSH >Tunnels
  2. Wprowadź szczegóły w następującym formacie:
Source Port 443

Destination IP: ACM Public IP Address

Destination Port: 443
  1. Kliknij przycisk Dodaj
  2. Dodaj tunel drugiego portu dla portu 9443 zgodnie z poniższymi szczegółami i kliknij przycisk Dodaj
Source Port 9443

Destination IP: ACM Public IP Address

Destination Port: 9443

Zrzut ekranu PUTTY przedstawiający konfigurację tunelu.  

  1. Otwórz interfejs użytkownika uaktualnienia IDPA pod następującym adresem URL:
https://localhost:9443/dataprotection-upgrade

Affected Products

Integrated Data Protection Appliance Family
Article Properties
Article Number: 000186345
Article Type: Solution
Last Modified: 30 May 2025
Version:  9
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.