AppSync: Kopia zapasowa Oracle przestaje odpowiadać i kończy się niepowodzeniem, gdy dysk dziennika archiwum jest pełny

Summary: Oprogramowanie AppSync powinno wcześniej przerwać działanie po wykryciu, że baza danych Oracle działa już w trybie hot-backup, tymczasem AppSync nadal próbuje kopiować dzienniki archiwum. AppSync przestaje odpowiadać przez około 1 godzinę, ponieważ dziennik archiwum jest pełny. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Oprogramowanie AppSync powinno wcześniej przerwać działanie po wykryciu, że baza danych Oracle działa już w trybie hot-backup, tymczasem AppSync nadal próbuje kopiować dzienniki archiwum. AppSync przestaje odpowiadać przez około 1 godzinę, ponieważ dziennik archiwum jest pełny.

Zdarzenia AppSync pokazują:      
 
2021-04-26 04:30:43.494,Utwórz kopię lokalną, ORCL_000013,Serwer<> AppSync,AppSync nie mógł wyciszyć bazy danych Oracle: orcl. Upewnij się, że nie został już wyciszony i że jest otwarty w trybie odczytu i zapisu.

2021-04-26 04:31:26.233,Utwórz kopię lokalną archLogs, MILE_000003,xxx,Ukończono wykonywanie cyklu serwisowego w <nazwie planu serwisowego>
 
Zwróć uwagę na lukę czasową:     

2021-04-26 05:30:45.294,Utwórz kopię lokalną, ORCL_000101,Serwer<> AppSync,Nie udało się zapisać co najmniej jednego dziennika archiwum bazy danych "orcl". W rezultacie utworzona kopia jest niespójna. Sprawdź, czy lokalizacje docelowe dzienników archiwum są prawidłowe, mają odpowiednie uprawnienia i dysponują wymaganą ilością wolnej przestrzeni dyskowej.

W dzienniku agenta kończącym się plikiem _beginBackup.log na hoście źródłowym widoczne są wpisy:      
 
2021-04-26 04:29:29.942 oracle.py[5007]:_execSql() SQLresult: ORA-01146: cannot start online backup - file 1 is already in backup
...
2021-04-26 04:29:31.833 oracle.py[6213]:getSqlQueryTimeout() SqlQueryTimeout value : : 3600
2021-04-26 05:29:31.915 oracle.py[6213]:getSqlQueryTimeout() SqlQueryTimeout value : : 360

Cause

Problem z oprogramowaniem AppSync.

Resolution

Istnieje poprawka eliminująca ten problem. Skontaktuj się z działem pomocy technicznej firmy Dell i powołaj się na numer ID tego artykułu podczas rozmowy.

Additional Information

Poprawka uniemożliwia wywołanie endBackup w sytuacji, gdy w kopii zapasowej znajdują się pliki. Dzięki temu plan serwisowy nie odpowiada przez godzinę.

Products

AppSync, AppSync
Article Properties
Article Number: 000187684
Article Type: Solution
Last Modified: 22 Oct 2024
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.