AppSync: O backup do Oracle para de responder e falha quando o disco de registro de arquivamento está cheio
Summary: O trabalho do AppSync deve apresentar uma falha inicial ao detectar que o banco de dados Oracle já está no modo de backup dinâmico. No entanto, AppSync continua tentando copiar os logs de arquivamento. O AppSync para de responder por cerca de 1 hora, pois o registro de arquivamento está cheio. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
O trabalho do AppSync deve apresentar uma falha inicial ao detectar que o banco de dados Oracle já está no modo de backup dinâmico. No entanto, AppSync continua tentando copiar os logs de arquivamento. O AppSync para de responder por cerca de 1 hora, pois o registro de arquivamento está cheio.
Os eventos do AppSync mostram:
2021-04-26 05:30:45.294,Criar cópia local, ORCL_000101,servidor<> do AppSync,Um ou mais logs de arquivo para o banco de dados 'orcl' falharam ao ser gravados. Como resultado, a cópia criada não é consistente. Verifique se os destinos do log de arquivamento estão corretos, contêm as permissões adequadas e têm o espaço livre necessário.
O log do agente que termina com _beginBackup.log no host de origem mostra:
Os eventos do AppSync mostram:
2021-04-26 04:30:43.494,Criar cópia local, ORCL_000013,servidor<> do AppSync,O AppSync não conseguiu desativar o banco de dados Oracle: orcl. Certifique-se de que ele não esteja desativado e que esteja aberto no modo de leitura e gravação.
2021-04-26 04:31:26.233,Criar archLogs cópia local, MILE_000003,xxx,Conclusão da execução de um ciclo de serviço no <nome do plano de serviço>
2021-04-26 04:31:26.233,Criar archLogs cópia local, MILE_000003,xxx,Conclusão da execução de um ciclo de serviço no <nome do plano de serviço>
Observe o intervalo de tempo:
2021-04-26 05:30:45.294,Criar cópia local, ORCL_000101,servidor<> do AppSync,Um ou mais logs de arquivo para o banco de dados 'orcl' falharam ao ser gravados. Como resultado, a cópia criada não é consistente. Verifique se os destinos do log de arquivamento estão corretos, contêm as permissões adequadas e têm o espaço livre necessário.
O log do agente que termina com _beginBackup.log no host de origem mostra:
2021-04-26 04:29:29.942 oracle.py[5007]:_execSql() SQLresult: ORA-01146: cannot start online backup - file 1 is already in backup
...
2021-04-26 04:29:31.833 oracle.py[6213]:getSqlQueryTimeout() SqlQueryTimeout value : : 3600
2021-04-26 05:29:31.915 oracle.py[6213]:getSqlQueryTimeout() SqlQueryTimeout value : : 360
...
2021-04-26 04:29:31.833 oracle.py[6213]:getSqlQueryTimeout() SqlQueryTimeout value : : 3600
2021-04-26 05:29:31.915 oracle.py[6213]:getSqlQueryTimeout() SqlQueryTimeout value : : 360
Cause
Problema no software do AppSync.
Resolution
Há um hotfix para esse problema. Entre em contato com o suporte técnico da Dell e informe o ID deste artigo.
Additional Information
O hotfix impossibilitará o acionamento do endBackup se já houver algum arquivo no backup. Isso evita que o plano de serviço não responda por uma hora.
Products
AppSync, AppSyncArticle Properties
Article Number: 000187684
Article Type: Solution
Last Modified: 22 Oct 2024
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.