AppSync: SQL Service plan failed during application discovery phase with error: Unable to connect to database.

Summary: SQL Service plan was failed during application discovery phase with error: Unable to connect to database Unable to connect to database . This can happen if either SQL database is not in online state or ODBC driver is not properly installed. Check the AppSync host plug-in log for more details. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Service plan was failed during application discovery phase with error: Unable to connect to database Unable to connect to database <Db name>. This can happen if either SQL database is not in online state or ODBC driver is not properly installed.
 Check the AppSync host plug-in log for more details.
 
AppSync Event logs:
 
Application discovery,7d2c438e-6ea7-4bb9-b515-0ce2594f9315,SQL_000141,<AppSync Server>,Unable to connect to database <Db name>. This can happen if either SQL database is not in online state or ODBC driver is not properly installed. Check the AppSync host plug-in log for more details.
 
AppSync Server logs:
 
07-02-2021 06:00:05.840 INFO [Thread-28455 (HornetQ-client-global-threads-320952484)] [com.emc.archway.service.eventservice.EventServiceBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> EVENT [SQL_000141]: Unable to connect to database hostname.master. This can happen if either SQL database is not in online state or ODBC driver is not properly installed. Check the AppSync host plug-in log for more details.(METADATA: TYPE-ERROR, TIME-2021-07-02 06:00:05.840-0600NATIVETIME-2021-07-02 06:00:05.643-0600, HOST-hostname.a.b.corporate. com, PHASE-Application discovery, THREAD=17152, USER-null, CATEGORY-GENERIC, SESSIONID-null)
07-02-2021 06:00:05.841 ERROR [Thread-28455 (HornetQ-client-global-threads-320952484)] [org.jboss.as.ejb3.invocation] [ASServer] [] WFLYEJB0034: EJB Invocation failed on component SqlServiceBean for method public com.emc.archway.objectmodel.host.sql.SqlServerInstances com.emc.archway.service.sqlservice.SqlServiceBean.discoverDatabases(com.emc.archway.context.ExecutionContext,com.emc.archway.objectmodel.host.AgentHost,com.emc.archway.objectmodel.host.sql.SqlServerInstances) throws java.net.UnknownHostException,com.emc.archway.service.eventservice.exceptions.HostPluginDownException: javax.ejb.EJBException: java.lang.RuntimeException
07-02-2021 06:00:06.032 ERROR [Thread-28455 (HornetQ-client-global-threads-320952484)] [com.emc.archway.application.sqlserver.SqlServerCommandListenerBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> Exception Occurred: RuntimeException
07-02-2021 06:00:06.035 ERROR [Thread-28455 (HornetQ-client-global-threads-320952484)] [com.emc.archway.application.sqlserver.SqlServerCommandListenerBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> Exception Occurred: EJBException, Message: java.lang.RuntimeException
07-02-2021 06:00:07.272 INFO [Thread-28456 (HornetQ-client-global-threads-320952484)] [com.emc.archway.service.eventservice.EventServiceBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> EVENT [MILE_000005]: Application discovery phase for hostname:Utility completed with errors(METADATA: TYPE-ERROR, TIME-2021-07-02 06:00:07.272-0600NATIVETIME-2021-07-02 06:00:07.272-0600, HOST-ASServer, PHASE-Application discovery, THREAD=Thread-28456 (HornetQ-client-global-threads-320952484), USER-null, CATEGORY-MILESTONE, SESSIONID-null)

Cause

Protection of SQL DB was failing because the user provided to AppSync for SQL didn't have the required privileges.
 


Resolution


Resetting the windows authentication of the DB’s to the proper user ​will resolve the Issue.

Steps to reset the authentication:
 
1. On the AppSync console, select Copy Management.
2. From the Copies drop-down, select Copies.
3. From the Select Application drop-down, select Microsoft SQL Server to display the instance page.
4. Select a database and click CONNECTION SETTINGS.
The SQL Server Connection settings dialog appears.
5. In the Authentication field, select one of the following per site requirements:
● Windows Authentication
● SQL Server Authentication
6. Specify values for the following fields:
● Username
● Password
7. Click OK

Affected Products

AppSync
Article Properties
Article Number: 000189823
Article Type: Solution
Last Modified: 22 Oct 2024
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.