Cyber Recovery 数据避风港 NetWorker 恢复失败,出现“无法将设备分配到池”错误

Summary: Cyber Recovery 数据避风港 NetWorker 恢复失败,出现“无法将设备分配到池”错误。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

在 CyberRecovery (CR) UI 中,运行 NetWorker 恢复后失败,并显示无法将设备分配到池错误。NetWorker 错误是请先卸载设备 device_name<然后再将其从池< pool_name> 中删除。


NW recoverapp 作业失败,并显示错误“无法将设备分配到池”
>从日志中可以观察到以下错误:

[2021-07-03 22:08:58.906] [ERROR] [apps] [appsUtils.go:121 HandleNWResponse()] : Error response is : {Message:please unmount device `<device_name>  before removing it from pool `<pool_name>.. Status:{Code:400 Class:Client Error Reason:Bad Request}}
[2021-07-03 22:08:58.906] [ERROR] [apps] [RecoverNetWorkerApp.go:657 NWSetPoolNames()] : Unable to assign device to pool. NetWorker Error is please unmount device `<device_name> before removing it from pool `<pool_name>.
[2021-07-03 22:08:58.907] [ERROR] [apps] [RecoverNetWorkerApp.go:150 RunNWWorkflow()] : Found error running task 60- Set NW Pool Names to DD Devices Error was: Unable to assign device to pool. NetWorker Error is please unmount device `<device_name> before removing it from pool `<pool_name>.

 

 

Cause

nsrdr 运行后,某些恢复的卷未卸载。当 CR 尝试重命名池名称时,池正在使用中。

Resolution

CR 19.8.0.2 及更高版本中包含此修复。升级 CR 以解决此问题。 

Affected Products

PowerProtect Cyber Recovery
Article Properties
Article Number: 000189942
Article Type: Solution
Last Modified: 16 Sept 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.