VxRail: "Yanıt Vermiyor" durumundaki VMware ESXi ana bilgisayarları için Sorun Giderme Rehberi
Summary: Bu makale, yanıt vermeyen ESXi ana bilgisayarlarında bulunan sanal makinelerle (VM'ler) ilgili sorunlara yönelik yanıtlar sağlar ve ESXi ana bilgisayarlarının kararlı bir duruma döndürülmesine yardımcı olur. ...
Symptoms
- ESXi ana bilgisayarı, vSphere Web İstemcisinde Yanıt Vermiyor olarak bildirildi.
- ESXi ana bilgisayarları vSphere Web İstemcisinden yönetilemiyor.
- Yanıt vermeyen ESXi ana bilgisayarına ve üzerindeki VM'lere ping gönderebilir.
- ESXi ana bilgisayarında çalışan SSH veya Uzak Masaüstü Protokolü (RDP) aracılığıyla VM'lere erişebilir.
Cause
Ana bilgisayardaki yönetim hizmetlerinden biri başarısız olmuş veya yanıt vermiyor durumuna geçmiş olabilir.
Bu, yönetim hizmetlerinin neden başarısız olduğu veya yanıt vermeyi durdurduğu hakkında kök neden analizi gerektirir. Kümeyi ve ESXi'yi kararlı bir duruma getirmeden önce VMware ESXi için tanılama bilgilerini toplama başlıklı VMware makalesine başvurarak vCenter Server ve ESXi ana bilgisayar günlüklerini toplayın.
Düğüm, günlükleri toplama komutlarına yanıt vermediği için bazen bu mümkün değildir. Bu makalenin Çözüm bölümündeki bilgileri inceleyin. Temel nedeni anlamak ve aşağıdaki bilinen sorunların sorunla ilgili olup olmadığını kontrol etmek için gerekirse günlükler Dell Desteği aracılığıyla analiz edilebilir.
Resolution
Yeniden Başlatılıyor hostd veya vpxa ana bilgisayar üzerinde vSphere Client'ta ana bilgisayar yönetilebilirliğini geri getirmeye yardımcı olabilir. Bu işlem, ESXi ana bilgisayarına bir SSH oturumu kullanılarak yapılır.
Yanıt Vermeyen ESXi ana bilgisayarına verilecek diğer bir yanıt, ESXi ana bilgisayarlarındaki Yönetim aracılarını yeniden başlatmaktır.
services.sh Komutu yeniden başlatın. Ana bilgisayarın yönetim aracılarının yeniden başlatılması, ana bilgisayardaki konuk VM'ler de dahil olmak üzere çalışan görevleri etkileyebilir.
ESXi ana bilgisayarlarının Yönetim aracılarını yeniden başlatma, doğrudan ESXi'de bir CLI veya SSH oturumu kullanılarak yapılır (SSH sorundan önce etkinleştirilmişse).
Ancak SSH etkin değilse BMC-iDRAC Bağlantı Noktasına erişim, yönetim hizmetlerinin yeniden başlatılabileceği ESXi DCUI Ekranına erişim sağlar. ESXi'de Yönetim aracılarını yeniden başlatma ile ilgili VMware makalesi 1003490 bakın.
DCUI yanıt vermeyebilir. Ortamı kararlı bir duruma geri getirmek için diğer tek seçenek, SSH veya RDP kullanarak sanal makinelerin manuel olarak kapatılmasıdır. İşlem tamamlandıktan sonra, BMC-iDRAC Güç Kontrolünü kullanarak ESXi ana bilgisayarını kararlı bir duruma getirmek için ESXi ana bilgisayarını kapatıp açın (yeniden başlatın).
VM'leri kapattıktan hemen sonra VM'leri sabit ana bilgisayarlara kaydedin, böylece Yanıt Vermeyen ESXi ana bilgisayarını yeniden başlatmadan önce VM'ler için kapalı kalma süresini azaltın. (Bu işlemden sonra sorunlu ESXi ana bilgisayarı yeniden başlatılabilir.) Bir Sanal Makineyi (VM) vCenter Server'da
vSphere Envanterine Kaydetme veya Ekleme ile ilgili VMware makalesini takip edin Sanal makineleri SSH veya RDP kullanarak kapatamıyorsanız ESXi ana bilgisayar SSH oturumu aracılığıyla bir VM'yi sonlandırın. ESXi ana bilgisayarında Sanal Makine kapatılamıyor VMware makalesine bakın
Sanal makine sorunları:
- Bir ESXi ana bilgisayarında VM'ler kapatılamıyor - 1014165
- ESXi ana bilgisayarında yanıt vermeyen bir VM'yi kapatma - 1004340
- VM'ler vCenter Server'da geçersiz veya sahipsiz görünüyor - 1003742
- VM'ler birden fazla ESX/ESXi Sunucusunda çalışıyor veya kayıtlı görünüyor - 319918
- Ana bilgisayar vSphere Client kullanılarak yönetilemediğinde komut satırından VM'yi açma - 1038043
- Yanıt vermeyi durduran bir VM'de sorun giderme - 1007819