PowerStore: Zbieranie danych kończy się niepowodzeniem, a interfejs użytkownika PowerStore Manager zgłasza nieprawidłowe informacje
Summary: Interfejs użytkownika programu PowerStore Manager zgłasza nieprawidłowe wartości, błędy lub niepowodzenie zadań. Materiały pomocnicze lub kolekcje danych (DC) pomocy nie uruchamiają się lub zawieszają się w stanie uruchomienia. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Występują następujące objawy:
- Materiały pomocnicze lub kolekcje danych (DC) nie uruchamiają się lub zawieszają się w stanie uruchomienia w interfejsie użytkownika PowerStore Manager. Uruchomienie DC przez CLI (uruchomienie svc_dc) kończy się niepowodzeniem z następującym komunikatem:
- FAILURE, Running too long
- Timed out receiving service data bundle command response from container
- Woluminy wyświetlają pojemność 0 GB.
- Nie można utworzyć lub usunąć żadnych obiektów (takich jak woluminy itd.).
- Nie można rozszerzyć woluminów — błąd 0xE0A080030019.
- Zasady ochrony nie działają (nowe migawki nie są tworzone, stare nie wygasają), a weryfikacja replikacji kończy się niepowodzeniem.
- Nie można wyświetlić ani zmienić stanu SSH. Error: There was an error retrieving this information. Unknown property is_ssh_enabled requested. (0xE04040020002)
- Błędy połączenia domeny LDAP
- Alerty dotyczące braku lub bliskiego braku miejsca na partycji głównej. Pliki temp kolekcji danych nie są usuwane z katalogu /cyc_var/cyc_service/tmp na węźle podrzędnym, co może prowadzić do zapełnienia partycji głównej. System generuje ostrzeżenia: Root partition usage of node X has exceeded Y% (codes: 0x00400601 or 0x00400602)
- W niektórych skrajnych przypadkach, gdy nie zostanie niezwłocznie podjęte żadne działanie w celu rozwiązania problemów z przestrzenią partycji głównej, węzeł dodatkowy może przejść do trybu serwisowego.
- Monitorowanie > kontroli > systemu Uruchomienie kontroli systemu nie powiodło się z komunikatem Fireman command failed. (0xE0F010200004)
Przykład problemu kolekcji danych, jak widać w programie PowerStore Manager:

Przykład niepowodzenia kontroli systemu w programie PowerStore Manager:

Cause
Wiele ujawnionych sesji logowania systemd prowadzi do przecieków pamięci w kontenerze usługi. W trakcie zbierania kolekcji danych wskutek braku pamięci, usługa fireman zostaje przerwana.
Jeśli system nie wykryje awarii po przerwaniu usługi fireman, usługa fireman pozostaje wyłączona.
Jeśli system nie wykryje awarii po przerwaniu usługi fireman, usługa fireman pozostaje wyłączona.
Resolution
Rozwiązanie
Poprawka zapobiegająca wystąpieniu tego problemu znajduje się w PowerStoreOS 2.1.1.0-1649887. Zaleca się uaktualnienie.Ta poprawka jest wymieniona w informacjach dotyczących wydania PowerStoreOS 2.1.1.0 w wersji A03 lub nowszej:
| Identyfikator problemu | Obszar funkcjonalny | Opis |
| MDT-361718 | PowerStore Manager (GUI) | Ze względu na problem ze ścieżką sterowania lub zasobami zarządzania z upływem czasu może wystąpić degradacja interfejsów użytkownika systemu PowerStore. Degradacja może spowodować powolną reakcję lub brak możliwości gromadzenia danych przez program PowerStore Manager. |
Obejście problemu
Uwaga: To obejście dotyczy tylko modeli PowerStore T. PowerStore X ma więcej wymagań i czynności, które należy wykonać przed ponownym uruchomieniem jakichkolwiek usług.
Jeśli problem już występuje, przed próbą aktualizacji skontaktuj się z działem pomocy technicznej firmy Dell lub z autoryzowanym przedstawicielem serwisu, podając identyfikator tego artykułu z bazy wiedzy.
Aby rozwiązać ten problem, gdy jest już obecny, należy ponownie uruchomić dwie usługi.
- Kontener usług w węźle, którego dotyczy problem.
- Ponowne uruchomienie kontenera usługi trwa około 10 minut.
- Brak wpływu na system poza krótką utratą dostępu do kontenera usług (ssh lub cli) węzła, którego dotyczy problem.
- Ścieżka sterowania (CP) lub usługi zarządzania.
- Ponowne uruchomienie zajmuje około pięciu minut.
- Brak wpływu na system poza krótką utratą dostępu do interfejsu użytkownika programu PowerStore Manager.
Po kilku minutach ilość miejsca na partycji głównej węzła dodatkowego spada do normalnego poziomu.
Jeśli partycja /cyc_cfs jest powyżej 85%, usuń stare kontrolery domeny z interfejsu użytkownika programu PowerStore Manager.
Po ponownym uruchomieniu usług mogą pojawić się alerty, takie jak:
- Alerty dotyczące łączności SupportAssist.
- Alerty Nie spełniono celu RPO replikacji.
- Alerty automatycznego usuwania migawek.
Additional Information
Identyfikowanie problemu
Sprawdź, czy występuje duża liczba ujawnionych sesji logowania (problem występuje, jeśli liczba jest większa niż 5000):[SVC:service@xxxxxxx-A ~]$ ll /run/systemd/system/ | wc -l |
Niepowodzenie kolekcji danych z błędem FAILURE, Running too long:
[SVC:service@xxxxxxx-A user]$ svc_dc list e62c17be-7716-49ef-a0b0-7365db383e6e |
Jeśli proces fireman nie istnieje już w głównym węźle, kontroler domeny ulegnie awarii z błędem „Timed receiving service data bundle command response from container”:
[SVC:service@xxxxxxx-B user]$ svc_dc list 7ad948cb-5029-422f-b4dc-5bf2f9abf512 |
Affected Products
PowerStoreProducts
Storage, Entry Level & Midrange, PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000TArticle Properties
Article Number: 000193605
Article Type: Solution
Last Modified: 29 May 2024
Version: 21
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.