PowerStore: A coleta de dados falha e a interface do usuário do PowerStore Manager relata informações anormais

Summary: A interface do usuário do PowerStore Manager informa valores incorretos, erros ou trabalhos com falha. Os materiais ou as coletas de dados (DC) de suporte não são executados ou travam no estado de execução. ...

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Symptoms

Os sintomas incluem:

  • Os materiais de suporte ou as coletas de dados (DC) não são executados ou travam no estado de execução na interface do usuário (IU) do PowerStore Manager. A execução de DCs via CLI (svc_dc execução) falha com: 
    • FAILURE, Running too long
    • Timed out receiving service data bundle command response from container
  • Os volumes exibem capacidade de 0 GB.  
  • Não é possível criar ou excluir objetos (como volumes e assim por diante).  
  • Os volumes não podem ser expandidos - erro 0xE0A080030019.
  • As políticas de proteção não funcionam mais (novos snapshots não são criados e os antigos não expiram) e a verificação da replicação falha.
  • Não é possível visualizar ou alterar o status do SSH. Error: There was an error retrieving this information. Unknown property is_ssh_enabled requested. (0xE04040020002)
  • Erros de conexão de domínio LDAP
  • Alertas para a partição raiz cheia ou sem espaço. Os arquivos CC temporários não são excluídos de /cyc_var/cyc_service/tmp no nó secundário, possivelmente levando a uma partição completa da raiz. O sistema gera avisos: Root partition usage of node X has exceeded Y% (codes: 0x00400601 or 0x00400602)
  • Em alguns casos extremos em que nenhuma ação é tomada imediatamente para resolver os problemas de espaço da partição raiz, o nó secundário pode entrar no modo de serviço.
  • Monitoramento > de Verificações do Sistema Executar Verificação > do Sistema falha com falha do comando Fireman. (0xE0F010200004)



Exemplo do problema de DC, como visto no PowerStore Manager:

image.png


Exemplo de falha de verificação do sistema, como visto no PowerStore Manager:

image.png


 

Cause

Muitas sessões de login vazadas do sistema geram uma perda de memória no contêiner de serviço. O serviço fireman no contêiner de serviço é eliminado durante a coleta de DC devido a uma condição de falta de memória.
O serviço fireman permanecerá inativo se o sistema não detectar sua falha depois que o mesmo for encerrado.

Resolution

Correção

A correção para evitar que esse problema ocorra está no PowerStoreOS 2.1.1.0-1649887. A recomendação é fazer upgrade.

Essa correção está listada nas notas da versão do PowerStoreOS versão 2.1.1.0 revisão A03 ou posterior:
ID do problema Área funcional Descrição
MDT-361718  PowerStore Manager (GUI) Devido a um problema com os recursos de gerenciamento ou caminho de controle, uma degradação das interfaces do usuário do sistema PowerStore pode ocorrer ao longo do tempo. A degradação pode causar uma resposta lenta ou a incapacidade do PowerStore Manager (IU) em coletar dados.

Solução temporária


Nota: Esta solução alternativa destina-se apenas a modelos PowerStore T. O PowerStore X tem mais requisitos e passos que devem ser executados antes de reiniciar quaisquer serviços.

Se o problema já estiver presente, entre em contato com o Suporte Técnico da Dell ou com seu Representante de Serviço Autorizado e cite o ID deste artigo da Base de Dados de Conhecimento antes de tentar atualizar.

Para resolver esse problema quando já presente, dois serviços devem ser reiniciados.
  • Contentor de serviço no nó afetado.
    • O contentor de serviço demora cerca de 10 minutos a reiniciar.
    • Nenhum impacto no sistema além de uma breve perda de acesso ao contêiner de serviço (ssh ou cli) do nó afetado.
  • Caminho de Controlo (CP) ou serviços de gestão.
    • Demora cerca de cinco minutos a reiniciar.
    • Nenhum impacto no sistema além de uma breve perda de acesso à interface de utilizador do PowerStore Manager.

Após alguns minutos, o espaço na partição raiz do nó secundário cai para níveis normais.

Se a partição /cyc_cfs estiver acima de 85%, elimine os controladores de domínio antigos da interface de utilizador do PowerStore Manager.

Poderá ver alguns alertas depois de reiniciar os serviços, tais como:
  • Alertas de conectividade do SupportAssist.
  • RPO de replicação não atendido alertas.
  • Alertas de eliminação automática de instantâneos.
Todos eles devem ser removidos automaticamente após o plano de ação. Dê-lhe tempo suficiente, pois alguns podem precisar esperar até o próximo ciclo RPO (replicação) ou agendamento de ajuste para começar.

Additional Information

Identificando o problema

Verifique se há um alto número de sessões de login vazadas (há um problema se o número for maior que 5000):
[SVC:service@xxxxxxx-A ~]$ ll /run/systemd/system/ | wc -l  
23251


O DC falha com o erro FAILURE, Running too long:
[SVC:service@xxxxxxx-A user]$ svc_dc list e62c17be-7716-49ef-a0b0-7365db383e6e
start_timestamp            2022-01-19 04:42:46
end_timestamp              2022-01-19 04:59:46
status                     FAILURE
status_message             FAILURE, Running too long.
state                      OFFLINE
description
profiles                   Essential
creator_type               Manual
compressed_size
uncompressed_size
uploaded                   Never
downloaded                 Never
id                         e62c17be-7716-49ef-a0b0-7365db383e6e


Se o processo do fireman não existir mais no nó principal, o DC apresentará falha com o erro "Timed out receiving service data bundle command response from container":
[SVC:service@xxxxxxx-B user]$ svc_dc list 7ad948cb-5029-422f-b4dc-5bf2f9abf512
start_timestamp            2021-10-21 06:03:11
end_timestamp              2021-10-21 06:03:11
status                     FAILURE
status_message             Timed out receiving service data bundle command response from container  
state                      OFFLINE
description                2021-10-21 Daily Data Collection
profiles                   Essential
creator_type               Scheduled
compressed_size
uncompressed_size
uploaded                   Never
downloaded                 Never
id                         7ad948cb-5029-422f-b4dc-5bf2f9abf512

Affected Products

PowerStore

Products

Storage, Entry Level & Midrange, PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T
Article Properties
Article Number: 000193605
Article Type: Solution
Last Modified: 29 May 2024
Version:  21
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