PowerMax: SRDF SRA Configuration Issues with Duplicate Device IDs in VMware SRM Protection Groups

Summary: If two array devices in two different array pairs have the same device ID, for example, 0003A, VMware is unable to properly identify the protection group for one pair. For example, array A and array B have pairs to array C and possibly array D. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

This example is taken from a lab:

If two array devices in two different array pairs have the same device ID, such as 0003A, VMware is unable to properly identify the protection group for one pair.

For example, three arrays (though they could have four), A, B, and C. They have configured pairs between A and C and B and C. By happenstance, one set of pairs from each has the same device ID on A and C: 

Pairs from A to C: 0003A - 001B8
Pairs from B to C: 0003A - 000F0

These are independent pairs, and the SRDF SRA has no issue recognizing them as shown below:
Array pairs 

After creating the Protection Group for each pair set, browse each one and look for the pairs. One of the Protection Groups will not recognize the device pairs, or sometimes it shows the wrong pair.

protection group 

Cause

The cause of the issue appears to be VMware SRM code. It relies on the device ID rather than using the NAA (or WWN) which is unique on each array.

Resolution

The current workaround is to Storage vMotion the VMs off one of the offending pairs to a new pair and then remove the pair from use in VMware. With careful planning, duplicate IDs can be avoided.

VMware has acknowledged the issue, and the fix will be in SRM 8.6. The current release date for this is June 2022 but subject to change. They have indicated they can provide backports to SRM 8.4/8.5 after that.

Affected Products

Symmetrix, VMAX, PowerMax 2000, PowerMax 2500, PowerMax 8000, PowerMax 8500, VMware
Article Properties
Article Number: 000195144
Article Type: Solution
Last Modified: 13 Mar 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.