PowerFlex-PXE-Start schlägt auf 14G-Servern mit X710-NICs fehl
Summary: Nodes können während der Bereitstellung nicht über PXE gestartet werden, wenn Intel X710-NICs vorhanden sind.
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Symptoms
- Zeitüberschreitung bei der BS-Installation während der Bereitstellung.
- Während der Node den PXE-Start ausführt, werden auf der iDRAC-Konsole Meldungen "Connection timed out" angezeigt.
- Fehlermeldung in der rackserver-Service-Tag>_exception.log< Datei:
#<ASM::UserException: The installation of the operating system for node 3Z5ZDF3 10.5.42.165 timed out.> /opt/asm-deployer/lib/asm/razor.rb:314:in `block_until_task_complete' /opt/asm-deployer/lib/asm/type/server.rb:3428:in `razor_block_until' /opt/asm-deployer/lib/asm/type/server.rb:1687:in `provision_server!' /opt/asm-deployer/lib/asm/service_deployment.rb:5146:in `process_server_with_types' /opt/asm-deployer/lib/asm/service_deployment.rb:2949:in `process_server' /opt/asm-deployer/lib/asm/service_deployment.rb:1409:in `block in create_component_thread'
Cause
- Dies ist eine Regression gegenüber einer Änderung zum Hinzufügen des LACP-Portkanals (mit aktiviertem Fallback) zu den PXE-Switchschnittstellen vor dem PXE-Installationsprozess.
- Vor dieser Änderung wurden Trunk-Ports verwendet. Die neue Methode funktioniert gut auf Mellanox-NICs, scheint aber auf Intel X710-NICs zu versagen.
Resolution
- Wenn der Node den PXE-Start startet, werden Meldungen zum Verbindungs-Timeout auf der iDRAC-Konsole angezeigt.
- Entfernen Sie nun den Portkanal von der PXE-Switch-Schnittstelle.
- Identifizieren Sie die Ports, die für das PXE-Netzwerk für jeden Node in der Bereitstellung verwendet werden, und suchen Sie die Kanalgruppe #, die auf jedem Port konfiguriert ist (Beispiel unten):
- Wechseln Sie in den Konfigurationsmodus auf der Schnittstelle für den ersten Node und führen Sie den folgenden Befehl aus:
no channel-group <channel-group #> mode active
- Wiederholen Sie die obigen Schritte für jeden Node im Service.
- Speichern Sie Ihre Konfigurationsänderungen auf dem Switch.
copy run start
- Wenn der Node neu gestartet wird (sollte sich aufgrund eines PXE-Startfehlers in einer Startschleife befinden), wird die PXE-Installation durchgeführt.
- Wenn der Dienst bereits fehlgeschlagen ist, müssen Sie die Portkanaländerungen vornehmen und den Dienst erneut versuchen.
- Starten Sie die Nodes neu und stellen Sie sicher, dass ESX vollständig über PXE installiert ist, bevor Sie den Service erneut versuchen.
Affected Products
PowerFlex rackArticle Properties
Article Number: 000195206
Article Type: Solution
Last Modified: 26 May 2025
Version: 4
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