X710 NICを搭載した14GサーバーでPowerFlex PXEブートが失敗する

Summary: Intel X710 NICが存在する場合に、導入中にノードがPXE起動に失敗します。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • 導入中にOSのインストールがタイムアウトしています。
  • ノードがPXE起動を実行している間、iDRACコンソールに「Connection timed out」というメッセージが表示されます。
PXE_boot_iDRAC_console
  • rackserver-<service tag>_exception.logファイルのエラー メッセージ:
#<ASM::UserException: The installation of the operating system for node 3Z5ZDF3 10.5.42.165 timed out.>

/opt/asm-deployer/lib/asm/razor.rb:314:in `block_until_task_complete'
/opt/asm-deployer/lib/asm/type/server.rb:3428:in `razor_block_until'
/opt/asm-deployer/lib/asm/type/server.rb:1687:in `provision_server!'
/opt/asm-deployer/lib/asm/service_deployment.rb:5146:in `process_server_with_types'
/opt/asm-deployer/lib/asm/service_deployment.rb:2949:in `process_server'
/opt/asm-deployer/lib/asm/service_deployment.rb:1409:in `block in create_component_thread'
 
 

Cause

  • これは、PXEインストール プロセスの前にLACPポート チャネル(フォールバックが有効になっている)をPXEスイッチ インターフェイスに追加するための変更によるリグレッションです。
  • この変更の前は、トランク ポートが使用されていました。この新しい方法は、Mellanox NICでは正常に機能しますが、Intel X710 NICでは失敗しているようです。

Resolution

  • ノードがPXE起動を開始すると、iDRACコンソールに接続がタイムアウトしたというメッセージが表示されます。
  • 次に、PXEスイッチ インターフェイスからポート チャネルを削除します。
    • 導入環境内の各ノードのPXEネットワークに使用されるポートを特定し、各ポートで構成されているチャネル グループ#を検索します(次の例を参照)。
port_config
  • 最初のノードのインターフェイスで構成モードに入り、次のコマンドを実行します。
no channel-group <channel-group #> mode active
  • サービス内のノードごとに上記の手順を繰り返します。
  • スイッチの設定変更を保存します。
copy run start
  • ノードが再起動すると(PXE起動の失敗により起動ループになっているはずです)、PXEインストールが完了します。
  • サービスがすでに失敗している場合は、ポート チャネルを変更してサービスを再試行する必要があります。
  • ノードを再起動し、サービスを再試行する前に、PXEを使用してESXが完全にインストールされていることを確認します。

Affected Products

PowerFlex rack
Article Properties
Article Number: 000195206
Article Type: Solution
Last Modified: 26 May 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.