IDPA Reporting and Analytics Server ei lähetä raportteja sähköpostitse

Summary: Tässä artikkelissa käsitellään tilannetta, jossa Integrated Data Protection Appliancen raportointi- ja analytiikkapalvelin ei voi lähettää raportteja sähköpostitse.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Ajoitettuja raportteja, jotka on määritetty julkaistaviksi sähköpostitse, ei lähetetä. 

Raportissa Jobs > Active Jobs näkyy, että raportit suoritettiin. Raporteissa on tietoja.

Seuraavat virheet näkyvät server.log, kun raportointimoduuli ja julkaisija on asetettu virheenkorjaukseen:
2021-10-08 08:00:00,540 ERROR [com.emc.dpa.command.notification.NotificationSenderMDB] (Thread-6255) Problems while sending email notification: javax.mail.MessagingException: Could not convert socket to TLS;
2021-10-08 08:00:00,540 ERROR [com.emc.dpa.command.notification.NotificationSenderMDB] (Thread-6255) Problems while sending email notification: javax.mail.MessagingException: Could not convert socket to TLS; nested exception is: javax.net.ssl.SSLException: Inbound closed before receiving peer's close_notify: possible truncation attack

Cause

SMTP-palvelin käyttää TLS 1.2:ta ja DPA TLS 1.1:tä. Tämä aiheuttaa sen, että SMTP-palvelin sulkee yhteyden, koska TLS-versiot eivät vastaa toisiaan.

Resolution

Korjaa ongelma seuraavasti:

  1. Tee kopio /opt/emc/dpa/services/standalone/configuration/standalone.xml tiedosto seuraavalla komennolla:
cp  /opt/emc/dpa/services/standalone/configuration/standalone.xml  /opt/emc/dpa/services/standalone/configuration/standalone.xml.bak
  1. Muokkaa /opt/emc/dpa/services/standalone/configuration/standalone.xml tiedosto avaamalla se vi ja tekemällä seuraavat muutokset:
Lisää seuraavat kaksi riviä <system-properties> osa:
<property name="mail.smtp.ssl.trust" value="*"/>
<property name="mail.smtp.ssl.protocols" value="TLSv1.2"/>
Tallenna sitten tiedosto ja poistu vi kanssa: :x
  1. Käynnistä DPA APP -palvelu uudelleen seuraavalla komennolla:
/opt/emc/dpa/services/bin/dpa.sh app restart
Ota yhteys Dell Technologies -tukeen , jos sinulla on kysyttävää tästä ongelmasta.

Affected Products

PowerProtect Data Protection Software
Article Properties
Article Number: 000196204
Article Type: Solution
Last Modified: 26 Mar 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.