Сервер отчетов и аналитики IDPA не отправляет отчеты с помощью электронной почты

Summary: В этой статье описывается ошибка сервера Integrated Data Protection Appliance Reporting and Analytics при отправке отчетов по электронной почте.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Запланированные отчеты, которые должны быть опубликованы по электронной почте, не отправляются. 

Отчет Задания > Активные задания показывает, что отчеты были запущены. Отчеты содержат данные.

Следующие ошибки отображаются в server.log после перевода модуля отчетов и издателя в отладку:
2021-10-08 08:00:00,540 ERROR [com.emc.dpa.command.notification.NotificationSenderMDB] (Thread-6255) Problems while sending email notification: javax.mail.MessagingException: Could not convert socket to TLS;
2021-10-08 08:00:00,540 ERROR [com.emc.dpa.command.notification.NotificationSenderMDB] (Thread-6255) Problems while sending email notification: javax.mail.MessagingException: Could not convert socket to TLS; nested exception is: javax.net.ssl.SSLException: Inbound closed before receiving peer's close_notify: possible truncation attack

Cause

SMTP-сервер использует TLS 1.2, а DPA — TLS 1.1. Это приводит к тому, что сервер SMTP закрывает соединение из-за несоответствия версий TLS.

Resolution

Для устранения этой проблемы выполните следующие действия:

  1. Создайте копию /opt/emc/dpa/services/standalone/configuration/standalone.xml с помощью следующей команды:
cp  /opt/emc/dpa/services/standalone/configuration/standalone.xml  /opt/emc/dpa/services/standalone/configuration/standalone.xml.bak
  1. Отредактируйте файл /opt/emc/dpa/services/standalone/configuration/standalone.xml , открыв его в vi и внеся следующие изменения:
Добавьте следующие две строки в файл <system-properties> секция:
<property name="mail.smtp.ssl.trust" value="*"/>
<property name="mail.smtp.ssl.protocols" value="TLSv1.2"/>
Затем сохраните файл и выйдите vi с: :x
  1. Перезапустите службу DPA APP с помощью следующей команды:
/opt/emc/dpa/services/bin/dpa.sh app restart
Если у вас возникли вопросы по этому вопросу, обратитесь в службу поддержки Dell Technologies .

Affected Products

PowerProtect Data Protection Software
Article Properties
Article Number: 000196204
Article Type: Solution
Last Modified: 26 Mar 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.