NetWorker: Bestandsindex kan niet worden verkregen vanwege het foutbericht "Kan index van pad 'pad' niet opzoeken. De indexsessie is ongeldig"
Summary: Incrementele back-up mislukt met fout: "Bestandsindex kon niet worden verkregen vanwege. De indexsessie is ongeldig."
Symptoms
De volledige back-up wordt zonder fouten voltooid, terwijl de incrementele back-up niet wordt voltooid met de volgende fout:
174422:save: Step (5 of 6) for PID-13894010: Reading the save sets and writing to the target device.
100690:save:<path>: File index could not be obtained due to <Unable to do Index lookup of path 'path'. The Index session is invalid
Dit kunnen ook berichten zijn die vergelijkbaar zijn met de onderstaande berichten in de beleidslogboeken:
Saving in pool '<Pool_Name>'.
Server enabled for immediate mode
...
RPC Authentication: <Client> failed to obtain RPCSEC_GSS credentials: Authentication error; why = Server rejected credential. Could not get a session key for GSS authentication. Perhaps this authentication method is not allowed/supported by both the local and remote machines.
Failed to create lgto_auth credential for RPCSEC_GSS: Could not get session key from <Client> for GSS authentication with <NWS>: Authentication error; why = Server rejected credential.
Unable to acquire the user credentials for direct save nsrmmd authentication: Could not get session key from <Client> for GSS authentication with <NWS>: Authentication error; why = Server rejected credential.
175297:save: Unable to set up the direct save with server '<NWS>': Could not get session key from <Client> for GSS authentication with <Client>: Authentication error; why = Server rejected credential.
98520:save: Falling back to agent-assisted indirect save
Cause
NetWorker maakt alleen back-ups van mappen met gewijzigde namen van mappen met ongewijzigde bestanden en submappen wanneer u expliciet mapnamen vermeldt in het kenmerk opslagset van de clientbron en als back-up hernoemd naar map is ingeschakeld.
Als het veld opgeslagen set bijvoorbeeld E:\ bevat en u de naam van de map E:\test wijzigt in E:\test1, maakt NetWorker geen back-up van de map E:\test1 zonder dat Back-up hernoemde mappen is ingeschakeld.
Wanneer het veld opgeslagen set E:\test bevat en u de naam van de map E:\test wijzigt in E:\test1, voert NetWorker een back-up uit van de map E:\test1 wanneer u Back-up hernoemde mappen inschakelt.
NetWorker voert een indexcontrole uit voor de directorywijzigingen sinds de laatste Full, maar dit kan afhankelijk zijn van het voltooien van een Client Direct-verbinding voordat we in deze fase komen.
Resolution
Selecteer Back-up hernoemd naar Mappen.
Als de naam van een directory verandert na een volledige back-up, maar er geen bestanden of submappen in de directory veranderen, neemt NetWorker de gewijzigde directory standaard niet op in volgende incrementele back-ups. Als u mappen met gewijzigde naam wilt opnemen in een incrementele back-up, selecteert u het kenmerk Back-up hernoemde mappen in de clientresource.
Deze instelling wordt gewijzigd vanuit de NetWorker Management Console door de Client Properties te openen:
Afbeelding 1: Schermafbeelding van het tabblad Clienteigenschappen in de NetWorker Management Console
Het tabblad Algemeen in de NetWorker Management Console heeft een selectievakje voor mappen met gewijzigde naam voor back-ups:
Afbeelding 2: Schermafbeelding van selectievakje voor back-up hernoemde mappen op het tabblad Algemeen van de NetWorker Management Console
Probleem opgelost met Client Direct-verbinding tussen de client en het Data Domain.
Het hebben van directe communicatie tussen de Klant en de PowerProtect DD heeft normaal gesproken de voorkeur, dus we moeten ervoor zorgen dat eventuele connectiviteitsproblemen tussen de klant en PowerProtect DD zijn opgelost:
Hostresolutie bijwerken:
Ervoor zorgen dat het bestand /etc/hosts of de DNS-vermeldingen (Domain Name System) op de client en Data Domain juist zijn geconfigureerd.
Beide systemen moeten elkaars hostnamen nauwkeurig omzetten.
NetWorker: Best practices voor het oplossen van problemen met naamresolutie
Controleer de netwerkverbinding:
Neem contact op met uw netwerkteam om ervoor te zorgen dat de volgende poorten in beide richtingen open en toegankelijk zijn:
111
2049
2051
2052
Zodra de connectiviteitsproblemen zijn opgelost, voert u de back-up voor de client uit om te controleren of de back-up foutloos is voltooid.
Poorten en naamomzetting kunnen worden geverifieerd op NetWorker-systemen met behulp van de nsrports bevelen:
nsrports -t HOSTNAME -p PORT
Schakel Client Direct uit in de eigenschappen van de client
Als u geen Client Direct-back-ups van de client naar het Data Domain kunt maken en u de directe koppeling niet kunt herstellen, moet u Client Direct mogelijk helemaal uitschakelen in het tabblad Clienteigenschappen Algemeen:
