NetWorker. Не удалось получить индекс файла из-за сообщения об ошибке: «Невозможно выполнить поиск по индексу пути "path". Сессия индексирования недействительна»
Summary: Сбой инкрементного резервного копирования с ошибкой: «Не удалось получить индекс файла из-за. Сеанс индексирования недействителен».
Symptoms
Полное резервное копирование выполняется успешно без ошибок, а инкрементное резервное копирование не завершается со следующей ошибкой:
174422:save: Step (5 of 6) for PID-13894010: Reading the save sets and writing to the target device.
100690:save:<path>: File index could not be obtained due to <Unable to do Index lookup of path 'path'. The Index session is invalid
Сюда также могут входить сообщения, подобные приведенным ниже, в журналах политик:
Saving in pool '<Pool_Name>'.
Server enabled for immediate mode
...
RPC Authentication: <Client> failed to obtain RPCSEC_GSS credentials: Authentication error; why = Server rejected credential. Could not get a session key for GSS authentication. Perhaps this authentication method is not allowed/supported by both the local and remote machines.
Failed to create lgto_auth credential for RPCSEC_GSS: Could not get session key from <Client> for GSS authentication with <NWS>: Authentication error; why = Server rejected credential.
Unable to acquire the user credentials for direct save nsrmmd authentication: Could not get session key from <Client> for GSS authentication with <NWS>: Authentication error; why = Server rejected credential.
175297:save: Unable to set up the direct save with server '<NWS>': Could not get session key from <Client> for GSS authentication with <Client>: Authentication error; why = Server rejected credential.
98520:save: Falling back to agent-assisted indirect save
Cause
NetWorker выполняет резервное копирование переименованных каталогов с неизмененными файлами и вложенными папками, только если имена каталогов явно перечислены в атрибуте набора данных для сохранения клиентского ресурса и если включена функция резервного копирования переименованного каталога.
Например, если поле набора сохранений содержит E:\ и вы переименовали каталог E:\test в E:\test1, NetWorker не выполнит резервное копирование каталога E:\test1, если параметр Резервное копирование переименованных каталогов не включен.
Если поле набора для сохранения содержит E:\test и каталог E:\test переименован в E:\test1, NetWorker выполняет резервное копирование каталога E:\test1 при включении функции резервного копирования переименованных каталогов.
NetWorker выполняет проверку индекса на предмет изменений каталога с момента последнего полного заполнения, но это может зависеть от успешного завершения подключения Client Direct до того, как мы перейдем к этому этапу.
Resolution
Выберите Резервное копирование переименованных каталогов.
По умолчанию, если имя каталога изменяется после полного резервного копирования, но файлы или вложенные папки в каталоге не изменяются, NetWorker не включает переименованный каталог в последующие инкрементные резервные копии. Чтобы включить переименованные каталоги в инкрементную резервную копию, выберите атрибут Резервное копирование переименованных каталогов в клиентском ресурсе.
Этот параметр можно изменить в NetWorker Management Console, открыв Client Properties:
Рис. 1. Снимок экрана вкладки «Свойства клиента» в NetWorker Management Console
На вкладке General в NetWorker Management Console имеется флажок Backup renamed directories:
Рис. 2. Снимок экрана с флажком для переименованных каталогов резервного копирования на вкладке General консоли управления NetWorker Management Console
Исправление прямого подключения клиента между клиентом и Data Domain.
Наличие прямых коммуникаций между Клиентом и PowerProtect DD является предпочтительным, поэтому мы должны убедиться, что любые проблемы с подключением между Клиентом и PowerProtect DD решены:
Обновление разрешения хоста:
Убедитесь, что файл /etc/hosts или записи системы доменных имен (DNS) на клиенте и Data Domain настроены правильно.
Обе системы должны точно разрешать имена хостов друг друга.
NetWorker. Передовые подходы к поиску и устранению неисправностей, связанных с разрешением имен
Проверьте подключение к сети:
Привлеките специалистов по сети, чтобы убедиться, что следующие порты открыты и доступны в обоих направлениях:
111
2049
2051
2052
После устранения проблем с подключением запустите резервное копирование для клиента, чтобы убедиться, что резервное копирование завершено успешно без ошибок.
Порты и разрешение имен можно проверить в системах NetWorker с помощью команды nsrports :
nsrports -t HOSTNAME -p PORT
Отключите Client Direct в свойствах клиента
Если вы не можете выполнить резервное копирование Client Direct с клиента в Data Domain и не можете исправить прямое подключение, возможно, потребуется полностью отключить Client Direct на вкладке «Общие» свойств клиента:
