NetWorker Console : « Impossible d’ouvrir la connexion du socket à l’hôte « NetWorker Server » sur le port 5672 »

Summary: Message d’erreur sur NetWorker Management Console (NMC) lorsque vous tentez d’afficher les détails d’un workflow sous l’onglet Monitoring : « Message bus cannot to open socket connection to host « Networkerserver_hostname » on port 5672 : A socket error occurred » s’affiche dans NMC. ...

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Symptoms

NetWorker Server et NetWorker Management Console (NMC) sont installés sur le même hôte.

La fenêtre de surveillance NMC affiche toutes les règles sur « Never Run » Ne jamais exécuter l’image; toutefois, les tâches de sauvegarde et de clonage se terminent conformément à la planification.

L’erreur suivante s’affiche dans NMC lors de la tentative d’ouverture des propriétés de workflow ou d’action :
Message bus unable to open socket connection to host "<NetWorker server hostname>" on port 5672: A socket error occurred

Capture d’écran du message d’erreur : Impossible d’ouvrir la connexion du socket à l’hôte sur le port 5672
Figure 1 : Capture d’écran du message d’erreur : Impossible d’ouvrir la connexion du socket à l’hôte sur le port 5672.

RabbitMQ utilise le port 5671 pour la communication via SSL.

Le port 5672 était l’ancien port utilisé pour les communications non-SSL (qui n’est plus utilisé).

Le GSTD se connecte à RabbitMQ pour obtenir et afficher les informations NMC à l’aide du port 5671.

Lorsque la connexion sur le port 5671 échoue, NetWorker NMC effectue un retour arrière et tente le port 5672, qui échoue également car RabbitMQ n’utilise plus ce port.

Le message d’erreur signale ensuite que le problème se situe sur le port 5672, mais le problème survient en réalité lors de la communication avec le port 5671.

Cause

GSTD ne parvient pas à communiquer avec RabbitMQ sur le port 5671.

Habituellement, cela signifie que le service RabbitMQ est en panne, mais cela peut potentiellement signifier qu’il y a un problème de connexion avec ce port (comme décrit dans l’article 210569)
  1. Si RabbitMQ fonctionne comme prévu, le port 5671 sur le serveur NetWorker doit être à l’état d’écoute. Vérifiez que le port 5671 est à l’état d’écoute. Pour vérifier ces ports, utilisez les commandes ci-dessous :
For Linux: 
netstat -ano | grep 5671 
ss -ano | grep 5671

For Windows: 
netstat -ano | findstr 5671
  1. Si le port ne s’affiche pas, assurez-vous que le service NSRD est en cours d’exécution (et que RabbitMQ doit donc avoir été ouvert une connexion à ce port).

Resolution

Procédure :
  1. Arrêtez les services NetWorker.
  2. Accédez au dossier /nsr/tmp et renommez le dossier RabbitMQ en RabbitMQ_old.
  3. Démarrez les services NetWorker. Vérifiez qu’un nouveau dossier RabbitMQ est généré dans le dossier /nsr/tmp. 
  4. Vérifiez l’état du port 5671 sur le NetWorker Server.
  5. Ouvrez NetWorker Management Console et vérifiez l’état du workflow.
  6. Si le problème est résolu, supprimez RabbitMQ_old de /nsr/tmp.

Additional Information

Commandes de test de connexion :
Linux: 
curl -kv <NetWorker server>:5671
openssl s_client -connect <NetWorker server>:5671

Windows (PowerShell): 
tnc <NetWorker server> -port 5671

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Affected Products

NetWorker

Products

Data Protection, NetWorker Family, NetWorker Series
Article Properties
Article Number: 000200132
Article Type: Solution
Last Modified: 09 Oct 2024
Version:  9
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