Dell Unity: SP panics with Secure NFS enabled when DNS servers are unavailable

Summary: This panic condition is due to a regression in Unity OE 5.1 related to Secure NFS in a Kerberos environment with a DNS server that is selectively responding or otherwise problematic. It can panic if a name service lookup is being performed and the name service is unreachable, and the lookup name does not exist in cache. This issue does not impact Unity OE 5.0.x releases. ...

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Symptoms

/EMC/C4Core/log/c4_safe_native.log may show panic backtraces similar to the following:
outerLoop reached new max of 1
CONSOLE> CSX RT: panic requested at: <file-unknown>:0 (thread: 139663546754816 aka 139663546754816) [PID:11804 TID:11604 CORE:4 [csx_ic_std.x] [nfs03_026] [04/11/2022 15:57:33 UTC]] (panic action:DEFAULT expr:<no-expr> flags:-) [info:0]
CSX RT: Fatal: Process received SIGSEGV:
        signo:11 si_errno:0 si_code:1 addr:0x4 PC:0x7f0af324b6d9
                module[/opt/dart/lib64/cdx.so:0x7f0af2c00000]
                symbol[<dladdr-returned-unknown>:0]
SIGSEGV(SEGV_MAPERR)@0x4
rax/rbx/rcx/rdx: 000000000000002c 0000000000000000 00007f05f4159588 00007f05f41795d8
rsi/rdi/rbp/rsp: 00007f05f41795c6 0000000000000004 00000000068afd78 00007f05f41795b8
r8 /r9 /r10/r11: 00007f060de84f1c 0000000000000000 000000000f254c30 00000000000343ec
r12/r13/r14/r15: 00007f05f41795c6 00007f05f41795d8 00007f060de84f18 00007f05f4179738
rip:             00007f0af324b6d9
CSX RT: panic backtrace: [f417a700] 00007f0b3e87b034 <csx_rt_proc_request_backtrace           +0x00000154> (sp=00007f0b3eb45ba0) proc=7f0b3e87aee0-7f0b3e87b50d csx_urt.so

The SP logs may also show generic DNS errors such as the following:
C4Core/log% zgrep "Connection timed out" EMCSystemLogBackup.log
"2022-04-11T13:42:19.403Z" "spa@APM00000000000" "Kittyhawk_safe" "11127" "unix/spa/root" "ALERT" "13:10760003" :: "The DNS client is unable to connect to name server  IP_2  : Connection timed out " :: Category=Audit Component=DART_DNS TimeZone=UTC
"2022-04-11T13:42:29.404Z" "spa@APM00000000000" "Kittyhawk_safe" "11127" "unix/spa/root" "ALERT" "13:10760003" :: "The DNS client is unable to connect to name server  IP_3  : Connection timed out " :: Category=Audit Component=DART_DNS TimeZone=UTC
...
"2022-04-11T15:47:10.638Z" "spb@APM00000000000" "Kittyhawk_safe" "11207" "unix/spb/root" "ALERT" "13:10760003" :: "The DNS client is unable to connect to name server  IP_2  : Connection timed out " :: Category=Audit Component=DART_DNS TimeZone=UTC
"2022-04-11T15:47:20.637Z" "spb@APM00000000000" "Kittyhawk_safe" "11207" "unix/spb/root" "ALERT" "13:10760003" :: "The DNS client is unable to connect to name server  IP_3  : Connection timed out " :: Category=Audit Component=DART_DNS TimeZone=UTC

Cause

This panic condition is due to a regression in Unity OE 5.1 related to Secure NFS in a Kerberos environment with a DNS server that is selectively responding or otherwise problematic. It can panic if a name service lookup is being performed and the name service is unreachable, and the lookup name does not exist in cache. This issue does not impact Unity OE 5.0.x releases.

Resolution

This issue is fixed in Unity OE 5.2.0.0.5.173 and newer.

Affected Products

Dell EMC Unity
Article Properties
Article Number: 000200255
Article Type: Solution
Last Modified: 29 May 2025
Version:  4
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