VxRail: Node Health-check Fails for Test 'unmap'
Summary: This health-check looks Guest Unmap setting on each node, which if enabled, can cause significant vSAN performance issues and impact Virtual Machine (VM) operations.
Symptoms
This health-check looks for Guest Unmap setting on each node, which if enabled, can cause significant vSAN performance issues and impact VM operations.
This health-check can produce any of the following results:
|
Test Result
|
Result code
|
Result Interpretation |
|---|---|---|
|
Pass
|
0
|
Unmap fairness is either disabled or does not cause a problem for upgrading. |
|
Warning
|
1
|
Unmap fairness is enabled. |
| Failure | 2 | There is no failure result for this test. |
| Critical | 3 | This test has no critical result. |
Each test that passes is not listed in the summary report, for ease of reading.
An example of the health-check output is shown below:
#========================#======#=========#====================================================================#==============# | Hostname / Category |Status Dell_KB | Warnings or Failures, unless tests Passed ; Product S.N. | #========================#======#=========#====================================================================#==============# | node03 | Warning 201608 | unmap: Unmap Fairness Enabled .|
Cause
VxVerify runs several tests on each node by uploading a minion heath-check program which detects issues that may cause upgrades to fail. Once the minion finishes, it saves a JSON file, which VxVerify then automatically retrieves. The JSON from each node is the merged with the VxRM based health-check results to produce a report for the whole cluster.
This test looks at the vSAN Guest Unmap setting on each host using the following node Shell command:
esxcfg-advcfg -g /VSAN/GuestUnmap
This test also looks at the vSAN Unmap Fairness setting:
esxcfg-advcfg -g /LSOM/unmapFairness
Resolution
Refer to 'Guest Unmap and Unmap fairness that is enabled may lead to vSAN issues' in article: DTA 201082: Dell VxRail: VxRail Response to VMware Proactive Customer Advisory for June 2022 (Log in as a registered Dell Support user may be required to view this article.)
Also see the VMware article https://kb.vmware.com/s/article/88832 (External Link)