Dell Unity: Неможливо синхронізуватися з NTP-серверами зі значенням stratum 6 або більше

Summary: Масиви Unity не можуть синхронізуватися з NTP-серверами, що мають stratum value 6 або більше. Помилка в Unisphere не відображається, але годинник Unity не синхронізується.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

У цьому прикладі NTP-сервер доступний, але Unity не може синхронізуватися з ним, оскільки значення stratum встановлено на 6. Це можна визначити з виводу svc_ntp -i команди; символ '*' на початку рядка для сервера NTP відсутній.
 
06:40:01 service spb:~/user# svc_ntp -i
NTP Status:
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
 xxx.xxx.xxx.xxx    LOCAL(0)      6 u   67   64  377    0.156  637.565   0.105
*peer            127.0.0.1        6 s   15   64  376    0.026    0.089   0.124

List of associations:
ind assid status  conf reach auth condition  last_event cnt
===========================================================
  1 45538  9024   yes   yes  none    reject   reachable  2
  2 45539  961a   yes   yes  none  sys.peer    sys_peer  1

List of servers in ntp.conf:
server      xxx.xxx.xxx.xxx iburst prefer                                          

Timestamps:
hwclock:1667976004 systime:1667976004 uptime:434601.65

Detailed Timestamps:
Wed Nov  9 06:40:05 UTC 2022
Wed Nov  9 06:40:06 2022  -0.953423 seconds
 06:40am  up 5 days  0:43,  6 users,  load average: 112.37, 112.83, 113.09


Cause

У /etc/ntp.conf, є наступний рядок, який не дозволяє ntpd синхронізуватися з серверами NTP, що мають значення stratum 6 або більше.

tos orphan 6

Resolution

 
Є два варіанти вирішення проблеми.
  1. Використовуйте сервери NTP, налаштовані зі значенням stratum 5 або менше.  
Зачекайте близько 10 хвилин, а потім виконайте команду svc_ntp -s , щоб перевірити, чи синхронізується ntpd із сервером NTP. На виході повинна бути зірочка зліва від запису NTP, а значення страту (st) має бути 5 або менше.
 
06:58:01 service spb:~/user# svc_ntp -i
NTP Status:
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
* xxx.xxx.xxx.xxx   LOCAL(0)      5 u   35   64  377    0.170   -0.123   0.041
 peer            127.0.0.1        6 s   47   64   37    0.059  -637.13   0.102

List of associations:
ind assid status  conf reach auth condition  last_event cnt
===========================================================
  1 25293  961a   yes   yes  none  sys.peer    sys_peer  1
  2 25294  9014   yes   yes  none    reject   reachable  1

List of servers in ntp.conf:
server      xxx.xxx.xxx.xxx iburst prefer                                          

Timestamps:
hwclock:1667977331 systime:1667977331 uptime:435927.21

Detailed Timestamps:
Wed Nov  9 07:02:12 UTC 2022
Wed Nov  9 07:02:13 2022  -0.953428 seconds
 07:02am  up 5 days  1:05,  7 users,  load average: 112.32, 112.49, 112.74
  1. Зверніться до служби технічної підтримки Dell або до ліцензованого постачальника послуг, щоб відредагувати /etc/ntp.conf файл і змінити значення в наступному рядку, щоб підтримувати значення stratum, більші за значення за замовчуванням 5, оскільки для цього методу потрібен root-доступ.
tos orphan 6

Максимальне підтримуване значення – 15.

Приклад:
# cp /etc/ntp.conf /cores/service/user/ntp.conf.bak
# sed -i -e 's/tos orphan 6/tos orphan 7/g' /etc/ntp.conf
# diff /etc/ntp.conf /cores/service/user/ntp.conf.bak
86c86
< tos orphan 7
---
> tos orphan 6

Потім виконайте наступну команду:


svc_ntp -s
Примітка: Значення tos orphan in /etc/ntp.conf може повернутися до початкового значення після оновлення Unity OE.

Примітка: Якщо різниця в часі занадто велика, може знадобитися перезавантаження процесора зберігання даних (SP), щоб зміни набули чинності.

Affected Products

Dell EMC Unity
Article Properties
Article Number: 000205159
Article Type: Solution
Last Modified: 09 Jun 2023
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.