NetWorker. Сбой резервного копирования с ошибкой: Не удается создать канал сеанса с nsrexecd на имени клиента хоста для выполнения команды «savefs ....
Summary: Сбой резервного копирования с ошибкой «Не удается создать канал сеанса с nsrexecd на имени клиента хоста» для выполнения команды «savefs -s server-name -c client-name -g
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Клиентское резервное копирование NetWorker завершается сбоем с ошибкой:
Unable to create session channel with nsrexecd on host client-name to execute command 'savefs -s server-name -c client-name'
Cause
Имеется проблема связи между сервером и клиентом.
Resolution
Начальные шаги.
- Убедитесь, что nsrexecd запущен на клиенте.
-
Linux: ps -ef | grep nsrexecd Windows: tasklist | findstr nsrexecd
-
- Если клиентские службы не запущены, запустите их и отслеживайте любые проблемы со службами:
-
Linux: systemctl start networker Windows: net start nsrexecd
-
- Проблемы с запуском сервиса можно отслеживать в daemon.raw файле клиента:
-
Linux: /nsr/logs/daemon.raw Windows: C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw
- Способ применения nsr_render_log: NetWorker. Как использовать nsr_render_log
- Как включить отрисовку журналов в режиме реального времени: NetWorker. Автоматический рендеринг daemon.raw в daemon.log в режиме реального времени
-
- Убедитесь, что разрешение имен работает правильно как на сервере NetWorker, так и на клиенте с помощью nslookup. Полностью определенное доменное имя, краткое имя и IP-адрес должны возвращаться правильно.
Поиск и устранение неисправностей подключения:
- Убедитесь, что nsradmin может подключаться от сервера к клиенту и наоборот:
nsradmin -p nsrexecd -s client-nameГде «client-name» — имя хоста клиента, определенное в конфигурации NetWorker.
- Проверьте диапазон портов на сервере и клиенте с портами nsrport, чтобы убедиться в их совпадении. NetWorker по умолчанию использует диапазон сервисных портов 7937–9936.
- На сервере NetWorker проверьте, какие порты/процессы видны из клиента.
nsrrprcinfo -p client-nameГде «client-name» — имя хоста клиента, определенное в конфигурации NetWorker.
PS C:\Windows\system32> nsrrpcinfo -p winsrvr2k16.emclab.local
PROGRAM VERSION PROTOCOL PORT SERVICE
100000 2 tcp 7938 nsrportmapper Port Mapper
100000 2 udp 7938 nsrportmapper Port Mapper
390436 1 tcp 8655 nsrexecd GSS Authentication
390435 1 tcp 9220 nsrexecd Resource Mirror
390113 1 tcp 7937 nsrexecd Remote Execution
390440 1 tcp 9500 nsrexecd_nsrfa Remote File Access
Порты динамически назначаются из настроенного диапазона портов.
- Проверьте, запущен ли на клиенте программный брандмауэр. Если есть, диапазон портов включает порты NetWorker:
- Linux:
firewall-cmd --list-all
Стандартная конфигурация с портами NetWorker по умолчанию:
- Linux:
# firewall-cmd --list-all
public (active)
target: %%REJECT%%
icmp-block-inversion: no
interfaces: ens3
sources:
services:
ports: 7937-9936/tcp
protocols:
forward: no
masquerade: no
forward-ports:
source-ports:
icmp-blocks:
rich rules:
rule family="ipv4" source ipset="jump-servers" service name="ssh" accept
Однако неправильная конфигурация межсетевого экрана может выглядеть следующим образом:
# firewall-cmd --list-all
public (active)
target: %%REJECT%%
icmp-block-inversion: yes
interfaces: ens3
sources:
services:
ports: 7936-7996/tcp
protocols:
forward: no
masquerade: no
forward-ports:
source-ports:
icmp-blocks: echo-reply echo-request
rich rules:
rule family="ipv4" source ipset="jump-servers" service name="ssh" accept
Windows:
Откройте брандмауэр Защитник Windows с расширенной безопасностью и просмотрите правила для входящего и исходящего трафика. Проверьте наличие каких-либо правил, блокирующих или ограничивающих диапазон портов NetWorker (как показано в случае nsrports). В столбце «Локальный порт» отображается диапазон портов, к которым применяется правило.
ПРИМЕЧАНИЕ. Необходимо привлечь администратора операционной системы для проверки любых дополнительных параметров операционной системы или программного обеспечения, которые потенциально могут блокировать обмен данными. Если конфигурации уровня операционной системы не найдены, возможно, связь заблокирована сетевым устройством. Кроме того, необходимо привлечь сетевого администратора к просмотру любых потенциальных сетевых конфигураций, которые могут блокировать обмен данными.
- По возможности рекомендуется использовать диапазон портов по умолчанию (7937–9936). Диапазон портов можно задать с помощью команды nsrports:
nsrports -S 7937-9936
Affected Products
NetWorker Family, NetWorkerArticle Properties
Article Number: 000207523
Article Type: Solution
Last Modified: 20 Apr 2023
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.