PowerFlex 3.X: telemetry service error while retrieving historical metrics

Summary: Your historical data for various PFxM resources is not being kept. A systemctl status of telemetry services is showing disabled.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

 [delladmin@pfxm ~]$ systemctl status telemetry
● telemetry.service - A telemetry service for Flex Manager
   Loaded: loaded (/etc/systemd/system/telemetry.service; enabled; vendor preset: disabled)
   Active: inactive (dead) since Tue 2023-03-28 13:18:06 EDT; 11min ago
  Process: 4426 ExecStart=/opt/local/telemetry/bin/telemetry.sh SuccessExitStatus=143 (code=killed, signal=TERM)
 Main PID: 4426 (code=killed, signal=TERM)

Cause

Versions prior to 3.8.3 run into this issue on occasion

Resolution

Follow the following steps to resolve this issue: *Warning! Step 5 erases all historical data.  You must manually save this if you want it.

 

Take a snapshot of the PFxM VM.
sudo systemctl stop telemetry
sudo systemctl stop ScaleIOMetricCollection.timer
sudo systemctl stop ipicabinet_metrics_collection.timer
sudo systemctl stop switch_metrics_collection.timer
curl -X DELETE 'http://localhost:9200/_all'
rm -rfv /var/log/elasticsearch/*log.gz
rm -rfv /var/log/elasticsearch/*gc.log*
systemctl restart elasticsearch
systemctl status elasticsearch
sudo systemctl start ScaleIOMetricCollection.timer
sudo systemctl start ipicabinet_metrics_collection.timer
sudo systemctl start switch_metrics_collection.timer
sudo systemctl start telemetry

If the issue is resolved to remove your snapshot of the PFxM VM.

Affected Products

PowerFlex rack, PowerFlex Appliance
Article Properties
Article Number: 000211724
Article Type: Solution
Last Modified: 01 Dec 2025
Version:  4
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