Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products

Dell VCFonVxRail: SDDC Manager workload domain upgrade precheck failed at step "VxRail Manager SSH connection" (VxRail Manager SSH-forbindelse)

Summary: En berettiget bruger på VxRail Manager kan være låst efter workload-domæneopgradering til VxRail 7.0.410 eller 7.0.411-version, ny opgraderingsforkontrol vil mislykkes på SDDC Manager.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

For VCF på VxRail-klynge

Efter opgradering til VxRail 7.0.410- eller 7.0.411-udgivelse og derefter udføre en ny opgradering vil SDDC Manager-opgraderingsforkontrol mislykkes ved trinnet "VxRail Manager SSH Connection" med fejlbeskrivelse "Auth fail".

image.png

Find "indstillinger"-brugeren kan ikke oprette forbindelse til VxRail Manager via SSH.

root@sddc-manager-controller [ ~ ]# ssh mystic@
FIPS mode initialized
Password:
Account locked due to 7 failed logins
 

Log på VxRail Manager som rodbruger via VM-konsollen i vCenter. Kør følgende kommando

pam_tally2 --user mystic

 

Observeret, at brugerlogin er blevet låst på grund af flere loginfejl.

image.png

 

For standard VxRail-klynge

Efter opgradering til 7.0.410 eller 7.0.411 kan brugeren muligvis også finde ud af, at "genstart"-brugeren ikke kan oprette forbindelse til VxRail Manager via SSH, da den er låst.

Cause

På grund af et SUSE Linux-problem, efter VxRail-opgradering til 7.0.410 eller 7.0.411, opdateres konfigurationsfilen /etc/pam.d/common-account ikke korrekt. (Hvis VxRail er direkte implementeret på 7.0.410 eller 7.0.411, så er det ikke berørt af dette problem.)

Når der oprettes en SSH-forbindelse fra andre VM'er til VxRail Manager VM via user, er det derfor stadig stigende, selvom login er gennemført. Når den når det maksimalt tilladte antal mislykkede logins, vil brugeren blive låst.

Bemærk: Direkte SSH til VxRail Manager er ikke berørt af dette problem. F.eks. vil et vellykket SSH-login fra din bærbare pc til VxRail Manager VM ikke medføre, at det mislykkede loginantal stiger. Så VCF på VxRail-miljøet vil opleve dette problem hyppigere, fordi der under opgraderingsforkontrol oprettes SSH-forbindelsen fra SDDC-manager-VM til VxRail Manager VM.

Resolution

Dette problem er løst i VxRail 7.0.450-versionen. Det betyder, at hvis VxRail allerede kører på 7.0.450 og derefter udfører en ny opgradering til en højere version, vil SDDC Manager-opgraderingsforkontrol ikke ramme dette problem.

Se nedenstående liste for at afgøre, om dine klynger er påvirket af dette problem:

  • VxRail opgraderes til 7.0.410 eller 7.0.411 og udfører derefter en ny opgradering til en højere version (herunder 7.0.450), hvorefter en opgradering af SDDC Manager rammer dette problem.
  • VxRail implementeres på 7.0.410 eller 7.0.411 (greenfield), og udfører derefter ny opgradering til en højere version, og SDDC Manager-opgraderingsforkontrol løser ikke dette problem.
  • VxRail kører på en pre-7.0.410-version og udfører derefter ny opgradering til en nyere version. SDDC Manager-opgraderingsforkontrol vil ikke støde på dette problem.
  • VxRail kører på 7.0.450 og udfører derefter en ny opgradering til en højere version. SDDC Manager-opgraderingsforkontrol vil ikke støde på dette problem.


    VCF på VxRail-kunder skal følge nedenstående tabel for at undgå, at SDDC Manager-opgraderingsforkontrol rammer dette problem:

      Kilde VxRail-version     Destinations-VxRail-version   Hvornår du skal anvende disse KB-løsningstrin
    7.0.400 AP-patch til 7.0.410  Når du har afsluttet VxRail Manager-opgraderingen til 7.0.410 
    7.0.400 AP-patch til 7.0.411  Når du har afsluttet VxRail Manager-opgraderingen til 7.0.411 
    7.0.410* AP-patch til 7.0.411  Før du aktiverer 7.0.411-opgradering 

    * Hvis du har installeret VCF 4.5 med VxRail 7.0.410 i greenfield, kan du ignorere KB. Se kun KB, hvis du har opgraderet til VxRail 7.0.410 fra en anden VxRail-version.

    Hvis SDDC Manager-opgraderingsforkontrollen allerede rammer dette problem, skal du også anvende disse KB-løsningstrin.


    Løsningstrin:

    =================

    1. Føj følgende linje til /etc/pam.d/common-account-filen i VxRail Manager. (Brug af virtuel maskinkonsol i vCenter med rodkonto, da SSH-forbindelsen ikke virker)

    account    required    pam_tally2.so
    

     

    2. Lås den bruger op ved at køre følgende kommando i VxRail Manager-kommandokonsollen med root-konto.

    pam_tally2 --user mystic --reset

     

    3. Når din konto er blevet låst op, skal brugeren validere den og forsøge at oprette en SSH-session til VxRail Manager ved hjælp af legitimationsoplysningerne.
     

    4. Fortsæt med forhåndskontrollen af arbejdsbelastningsdomæneopgraderingen på SDDC Manager.

    Additional Information

    Brugeren kan søge efter de korrekte adgangskoder til VxRail Manager fra SDDC Manager ved at køre lookup_passwords kommando som vist nedenfor.

    root@sddc-manager-controller [ /home/vcf ]# lookup_passwords
    Handlingen til søgning af adgangskode kræver administratorbrugerlegitimationsoplysninger. Se VMware Cloud Foundation-administrationsvejledningen til opsætning af ADMIN-bruger.
    Understøttede enhedstyper: ESXI VCENTER PSC NSX_MANAGER NSX_CONTROLLER NSXT_MANAGER NSXT_EDGE VRSLCM VRLI VROPS VRA WSA BACKUP VXRAIL_MANAGER AD
    Indtast en enhedstype fra ovenstående liste:
    VXRAIL_MANAGER Indtast sidenummer (valgfrit):
    Angiv sidestørrelse (valgfri, standard=50):
    Indtast brugernavn: administrator@vsphere.lokal
    Indtast adgangskode: .lokale>
    VXRAIL_MANAGER
    identifikatorer: 172.16.6.129,app01-vxrm.test.local
    workload: app01-md
    brugernavn: adgangskode
    :
    type: SSH-kontotype
    : SYSTEM


    VXRAIL_MANAGER identifikatorer: 172.16.6.129,app01-vxrm.test.local
    workload: app01-md
    brugernavn: rodadgangskode
    :
    type: SSH-kontotype
    : SYSTEM

    Affected Products

    VxRail
    Article Properties
    Article Number: 000212019
    Article Type: Solution
    Last Modified: 01 Jun 2023
    Version:  6
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.