VCF sur VxRail : Échec de la vérification préalable à la mise à niveau du domaine de charge applicative SDDC Manager à l’étape « Connexion SSH de VxRail Manager »

Summary: L’utilisateur Mystic sur VxRail Manager peut être verrouillé après la mise à niveau du domaine de charge applicative vers la version VxRail 7.0.410 ou 7.0.411. La nouvelle vérification préalable à la mise à niveau échoue sur SDDC Manager. ...

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Symptoms

Pour un cluster VCF sur VxRail

Après la mise à niveau vers la version VxRail 7.0.410 ou 7.0.411, puis effectuez une nouvelle mise à niveau, la vérification préalable à la mise à niveau de SDDC Manager échoue à l’étape « Connexion SSH VxRail Manager » avec la description de l’erreur "Auth fail."

Capture d’écran montrant l’erreur d’authentification

L’utilisateur « mystic » ne parvient pas à se connecter à VxRail Manager via SSH.

root@sddc-manager-controller [ ~ ]# ssh mystic@<VxM-IP>
FIPS mode initialized
Password:
Account locked due to 7 failed logins

 

Connectez-vous à VxRail Manager en tant qu’utilisateur root à l’aide de la console de machine virtuelle dans vCenter Exécutez la commande suivante.

pam_tally2 --user mystic

 

Il a été observé que le mystic de l’utilisateur a été verrouillé en raison de plusieurs échecs de connexion.

Capture d’écran du compte mystic affichant verrouillé 

 

Pour un cluster VxRail standard

Après la mise à niveau vers la version 7.0.410 ou 7.0.411, il se peut également que l’utilisateur « mystic » ne puisse pas se connecter à VxRail Manager via SSH, car il est verrouillé.

Cause

En raison d’un problème Ce lien hypertexte renvoie à un site Web extérieur à Dell Technologies.SUSE Linux, après la mise à niveau de VxRail vers la version 7.0.410 ou 7.0.411, le fichier de configuration /etc/pam.d/common-account n’a pas pu être mis à jour. (Si VxRail est directement déployé à la version 7.0.410 ou 7.0.411, il n’est pas affecté par ce problème.)

Par conséquent, lors de l’établissement d’une connexion SSH entre d’autres machines virtuelles et la machine virtuelle VxRail Manager via mystic user, même si la connexion réussit, le nombre d’échecs de connexion est toujours incrémenté. Une fois qu’il atteint le nombre maximal autorisé d’échecs de connexion, l’utilisateur Mystic est verrouillé.

Remarque : Ce problème n’affecte pas la connexion directe SSH à VxRail Manager. Par exemple, la connexion SSH réussie depuis votre ordinateur portable à la machine virtuelle VxRail Manager n’entraîne pas d’augmentation du nombre d’échecs de connexion. Un environnement VCF sur VxRail rencontre ce problème plus fréquemment, car lors de la vérification préalable à la mise à niveau, la connexion SSH est établie entre la machine virtuelle SDDC Manager et la machine virtuelle VxRail Manager.

Resolution

Ce problème est résolu dans la version 7.0.450 de VxRail. Cela signifie que lorsque VxRail est déjà en cours d’exécution sur la version 7.0.450 et effectue une nouvelle mise à niveau vers une version supérieure, la vérification préalable à la mise à niveau de SDDC Manager ne résout pas ce problème.

Consultez la liste ci-dessous pour déterminer si vos clusters sont concernés par ce problème :

  • VxRail est mis à niveau vers la version 7.0.410 ou 7.0.411, puis en effectuant une nouvelle mise à niveau vers une version supérieure (y compris 7.0.450), la vérification préalable à la mise à niveau de SDDC Manager résout ce problème.
  • VxRail est déployé à la version 7.0.410 ou 7.0.411 (greenfield), puis effectuez une nouvelle mise à niveau vers une version supérieure. La vérification préalable à la mise à niveau de SDDC Manager ne résoudra pas ce problème.
  • VxRail s’exécute sur une version antérieure à la version 7.0.410, puis effectuez une nouvelle mise à niveau vers une version supérieure. La vérification préalable à la mise à niveau de SDDC Manager ne résoudra pas ce problème.
  • VxRail s’exécute sur la version 7.0.450, puis effectue une nouvelle mise à niveau vers une version supérieure. La vérification préalable à la mise à niveau de SDDC Manager ne résoudra pas ce problème.


    Les clients VCF sur VxRail suivent le tableau ci-dessous pour éviter que la vérification préalable à la mise à niveau de SDDC Manager ne rencontre ce problème :

      Source VxRail Version     Version VxRail cible   Quand appliquer les étapes de contournement de la base de connaissances
    7.0.400 Correctif AP vers la version 7.0.410  Une fois que vous avez terminé la mise à niveau de VxRail Manager vers la version 7.0.410. 
    7.0.400 Correctif AP vers la version 7.0.411  Une fois que vous avez terminé la mise à niveau de VxRail Manager vers la version 7.0.411. 
    7.0.410* Correctif AP vers la version 7.0.411  Avant d’activer la mise à niveau vers la version 7.0.411. 

    * Si vous avez installé VCF 4.5 avec VxRail 7.0.410 dans un nouveau site, vous pouvez ignorer la base de connaissances. Reportez-vous à la base de connaissances uniquement si vous avez effectué une mise à niveau vers VxRail 7.0.410 à partir d’une autre version de VxRail.

    Si la vérification préalable à la mise à niveau de SDDC Manager a déjà rencontré ce problème, appliquez également ces étapes de contournement.


    Étapes de la solution :

    =================

    1. Ajoutez la ligne suivante au champ /etc/pam.d/common-account dans VxRail Manager. (Utilisation de la console de la machine virtuelle dans vCenter avec un compte root, car la connexion SSH ne fonctionne pas)

    account    required    pam_tally2.so
    

     

    2. Déverrouillez l’utilisateur mystic en exécutant la commande suivante dans la console de commande VxRail Manager avec un compte root.

    pam_tally2 --user mystic --reset

     

    3. Une fois le compte mystic déverrouillé, l’utilisateur doit le valider et essayer d’établir une session SSH sur VxRail Manager à l’aide des informations d’identification mystic.
     

    4. Procédez à la vérification préalable à la mise à niveau du domaine de charge applicative sur SDDC Manager.

    Additional Information

    L’utilisateur peut rechercher les mots de passe corrects de VxRail Manager à partir de SDDC Manager en exécutant la commande lookup_passwords comme indiqué ci-dessous.
     

    root@sddc-manager-controller [ /home/vcf ]# lookup_passwords
    Password lookup operation requires ADMIN user credentials. Please refer VMware Cloud Foundation Administration Guide for setting up ADMIN user.
    Supported entity types: ESXI VCENTER PSC NSX_MANAGER NSX_CONTROLLER NSXT_MANAGER NSXT_EDGE VRSLCM VRLI VROPS VRA WSA BACKUP VXRAIL_MANAGER AD
    Enter an entity type from above list: VXRAIL_MANAGER
    Enter page number (optional):
    Enter page size (optional, default=50):
    Enter Username: administrator@vsphere.local
    Enter Password:<password_of_administrator@vsphere.local>
            VXRAIL_MANAGER
            identifiers: 172.16.6.129,app01-vxrm.test.local
            workload: app01-md
                    username: mystic
                    password: <passord_of_mystic>
                    type: SSH
                    account type: SYSTEM
            VXRAIL_MANAGER
            identifiers: 172.16.6.129,app01-vxrm.test.local
            workload: app01-md
                    username: root
                    password: <passord_of_root>
                    type: SSH
                    account type: SYSTEM

     

    Affected Products

    VxRail, VxRail E560 VCF, VxRail E560F VCF, VxRail E560N VCF, VxRail G560 VCF, VxRail G560F VCF, VxRail P570 VCF, VxRail P570F VCF, VxRail P580N VCF, VxRail S570 VCF, VxRail V570 VCF, VxRail V570F VCF
    Article Properties
    Article Number: 000212019
    Article Type: Solution
    Last Modified: 21 Aug 2025
    Version:  8
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