PowerProtect Data Manager 19.12 e versioni precedenti: Utilizzo elevato della CPU da parte del servizio agent

Summary: Elevato utilizzo della CPU (Central Processing Unit) da parte del processo del sistema operativo (OS) del servizio agente.

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Symptoms

Il sistema operativo di un host mostra un elevato utilizzo della CPU quando è in esecuzione PowerProtect Data Manager 19.12 o versioni precedenti.

Non sono presenti sintomi visibili nei registri, ma il comportamento si verifica nell'applicazione Gestione attività dell host.

Cause

Esistono due cause note per il comportamento dei picchi della CPU:

  1. Il file tasks.db deve ricaricarsi per ogni iterazione. Se è grande, ogni volta che ciò accade, provoca un picco nell'utilizzo della CPU.
  2. La versione 19.11 utilizza una chiamata API (Application Programming Interface) lockbox per ogni chiamata API della sessione GET.

Questa chiamata API lockbox consuma più CPU del normale. Il polling per un'API di sessione GET viene eseguito ogni 30 secondi.
In questa richiesta è presente una chiamata non necessaria che tenta di decrittografare la password ogni volta.  

Resolution

Versioni interessate: Questo problema interessa v19.12 e versioni precedenti.

Soluzione alternativa: 

  1. Arrestare il servizio agent.
  2. Rinominare il tasks.db in C:\Program Files\DPSAPPS\AgentService\dbs\v1.
  3. Riavviare il servizio agent.

Versione fissa: Il problema non è presente nella v19.13 e versioni successive.

 

Affected Products

PowerProtect Data Manager, PowerProtect Software
Article Properties
Article Number: 000212583
Article Type: Solution
Last Modified: 06 Oct 2025
Version:  3
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