OpenManage Enterprise: Plugin Group Cannot be re-created After Deleting Services Plugin
Summary: Customers leveraging APIs to create and delete Services Plugin groups find that if they leverage the OpenManage Enterprise (OME) GroupService API (GroupService/Groups(#)) to delete the plugin groups the Services Plugin group can no longer be manageable and cannot be re-created due to 'Group already exists' error. ...
Symptoms
Deleting a Services Plugin group using the OpenManage Enterprise (OME) GroupService/Groups API causes the group to no longer be created using either the web UI or Services Plugin Create Or Update Group API.
Re-creating the group from the web UI displays the error 'Unable to create or update a group'.
Re-creating the group using the Services Plugin API (POST /api/SupportAssistService/Actions/SupportAssistService.CreateOrUpdateGroup) returns the following 500 response:
{
"error": {
"code": "Base.1.0.GeneralError",
"message": "A general error has occurred. See ExtendedInfo for more information.",
"@Message.ExtendedInfo": [
{
"MessageId": "CGEN6001",
"RelatedProperties": [],
"Message": "Unable to process the request because an error occurred: SAE-020100 : A group with this name already exists. Change the name of this group, then try again..",
"MessageArgs": [
"SAE-020100 : A group with this name already exists. Change the name of this group, then try again."
],
"Severity": "Critical",
"Resolution": "Retry the operation. If the issue persists, contact your system administrator."
}
]
}
}
Cause
The Services Plugin leverages a separate SDK database to store plugin-based data like device inventory and group data. When a Services Plugin group is created the details are stored in the SDK database using a unique group UID and then OpenManage Enterprise (OME) group information is propagated into the OpenManage Enterprise (OME) database using a group ID.
The two IDs are associated using the supportassist.group_saegroup_association table in the OpenManage Enterprise (OME) database, and when the group is deleted using the OpenManage Enterprise (OME) GroupService API the deletion is not rolled into the SDK database leaving orphaned entries.
Resolution
Dell engineering is aware of the issue, and will offer a fix in a future release of the Services Plugin.
Until then customers should only leverage Services Plugin APIs to create, manage, and delete plugin groups.
If the customer cannot re-create groups that were previously deleted, escalate to DE or IPS as FSD will be required to clean up the orphaned groups within the Services Plugin SDK database.