OpenManage Enterprise: Plugin Group Cannot be re-created After Deleting Services Plugin

Summary: Customers leveraging APIs to create and delete Services Plugin groups find that if they leverage the OpenManage Enterprise (OME) GroupService API (GroupService/Groups(#)) to delete the plugin groups the Services Plugin group can no longer be manageable and cannot be re-created due to 'Group already exists' error. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Deleting a Services Plugin group using the OpenManage Enterprise (OME) GroupService/Groups API causes the group to no longer be created using either the web UI or Services Plugin Create Or Update Group API.
 
Re-creating the group from the web UI displays the error 'Unable to create or update a group'.
ome 
 
Re-creating the group using the Services Plugin API (POST /api/SupportAssistService/Actions/SupportAssistService.CreateOrUpdateGroup) returns the following 500 response:
 

{
    "error": {
        "code": "Base.1.0.GeneralError",
        "message": "A general error has occurred. See ExtendedInfo for more information.",
        "@Message.ExtendedInfo": [
            {
                "MessageId": "CGEN6001",
                "RelatedProperties": [],
                "Message": "Unable to process the request because an error occurred: SAE-020100 : A group with this name already exists. Change the name of this group, then try again..",
                "MessageArgs": [
                    "SAE-020100 : A group with this name already exists. Change the name of this group, then try again."
                ],
                "Severity": "Critical",
                "Resolution": "Retry the operation. If the issue persists, contact your system administrator."
            }
        ]
    }
}

 

Cause

The Services Plugin leverages a separate SDK database to store plugin-based data like device inventory and group data. When a Services Plugin group is created the details are stored in the SDK database using a unique group UID and then OpenManage Enterprise (OME) group information is propagated into the OpenManage Enterprise (OME) database using a group ID.
 
The two IDs are associated using the supportassist.group_saegroup_association table in the OpenManage Enterprise (OME) database, and when the group is deleted using the OpenManage Enterprise (OME) GroupService API the deletion is not rolled into the SDK database leaving orphaned entries.

Resolution

Dell engineering is aware of the issue, and will offer a fix in a future release of the Services Plugin.

Until then customers should only leverage Services Plugin APIs to create, manage, and delete plugin groups.
If the customer cannot re-create groups that were previously deleted, escalate to DE or IPS as FSD will be required to clean up the orphaned groups within the Services Plugin SDK database.

Affected Products

OpenManage Enterprise Services, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R470, PowerEdge R540, PowerEdge R550, PowerEdge R570, PowerEdge R640 , PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R6715, PowerEdge R6725, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R770AP, PowerEdge R7715, PowerEdge R7725, PowerEdge R7725xd, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T40, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000215072
Article Type: Solution
Last Modified: 09 Sept 2025
Version:  2
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