PowerStore : Utilisateurs LDAP spécifiques incapables de se connecter à l’interface utilisateur PowerStore avec une erreur d’authentification générale à partir de l’interface utilisateur graphique et « No unique from logs »

Summary: PowerStore : Utilisateurs LDAP spécifiques incapables de se connecter à l’interface graphique PowerStore avec une erreur d’authentification générale à partir de l’interface utilisateur et « Non unique » dans les logs ...

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Symptoms

Certains utilisateurs sont en mesure de se connecter tandis que d’autres ne parviennent pas à se connecter.
Le client possède plusieurs comptes dans le domaine principal et/ou le sous-domaine. Exemple :
Joe Doe fait partie du domaine principal example.com
Joe Doe fait également partie du sous-domaine sub.example.com (il s’agit d’un sous-domaine de example.com) 
Lechemin de recherche utilisateur est configuré pour effectuer une recherche de domaine global dans le domaine et l’attribut est sAMAccountName.
exemple de chemin de recherche :
dc=example,dc=com
Erreur LDAP détectée dans les logs :
LDAP authentication failed: LDAP account search for [user account]com error:Ldap Search Error: Not Unique 

Cause

Le problème est dû à la configuration AD où les utilisateurs sont trouvés deux fois dans le domaine principal ou le sous-domaine lorsque l’attribut de recherche est sAMAccountName.

Resolution

Il est recommandé de spécifier le chemin de recherche de l’utilisateur et du groupe vers une unité d’organisation ou un répertoire spécifique plutôt qu’une recherche globale. Si l’environnement LDAP ne prend pas en charge cette opération, car les utilisateurs se trouvent dans une autre UO, la modification de l’ID d’attribut de sAMAccountName à userPrincipalName à partir du paramètre avancé LDAP permet de résoudre ce problème.

NOTE: L’utilisateur doit se connecter à l’aide du nom de domaine complet (FQDN) Joe_Doe@example.com.

Comment modifier l’ID d’attribut du chemin de recherche utilisateur LDAP avant le code
1 de la version 3.5. Connectez-vous à l’interface graphique
PowerStore 2. Cliquez sur le paramètre en haut à droite
3. Dans le panneau de gauche, faites défiler vers le bas jusqu’à ce que vous trouviez le service
d’annuaire 4. Cliquez sur Modifier la configuration
LDAP 5. Dans le coin gauche, vous verrez les paramètres avancés, cliquez sur le lien
bleu 6. Recherchez l’ID d’attribut sous le chemin de recherche. Par défaut, la valeur est sAMAccountName
7. Remplacez la valeur par userPrincipalName
8. Vérifiez la connexion et relancez la tentative

de modification de l’ID d’attribut pour le chemin de recherche de l’utilisateur LDAP sur le code 3.5 ou une version ultérieure
1. Connectez-vous à l’interface graphique
PowerStore 2. Cliquez sur le paramètre en haut à droite
3. Dans le panneau de gauche, faites défiler vers le bas jusqu’à ce que vous trouviez l’authentification sous sécurité
4. Cliquez sur Modifier la configuration
LDAP 5. Dans le coin gauche, vous verrez les paramètres avancés, cliquez sur le lien
bleu 6. Recherchez l’ID d’attribut sous le chemin de recherche. Par défaut, la valeur est sAMAccountName
7. Remplacez la valeur par userPrincipalName
8. Vérifier la connexion et réessacter

Affected Products

Entry Level & Midrange, PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 1200T, PowerStore 3000X, PowerStore 3000T, PowerStore 3200T, PowerStore 5000X, PowerStore 5000T

Products

Storage, PowerStore 500T, PowerStore 5200T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T, PowerStore 9200T, PowerStoreOS
Article Properties
Article Number: 000215510
Article Type: Solution
Last Modified: 29 Sept 2023
Version:  2
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