PowerStore. Определенным пользователям LDAP не удается войти в пользовательский интерфейс PowerStore с общей ошибкой аутентификации из графического интерфейса пользователя и сообщением «No unique from logs»
Summary: PowerStore. Определенным пользователям LDAP не удается войти в графический интерфейс пользователя PowerStore с общей ошибкой аутентификации из графического интерфейса пользователя и сообщением «Not unique» из журналов ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Некоторые пользователи могут войти в систему, в то время как другие пользователи не могут войти в систему.
Заказчик имеет несколько учетных записей в основном домене и/или поддомене. Пример.
пример пути поиска:
В журналах обнаружена ошибка LDAP:
Заказчик имеет несколько учетных записей в основном домене и/или поддомене. Пример.
Джо Доу является частью основного доменного example.com
Джо Доу также является частью поддомена sub.example.com (это поддомен example.com).
Путьпоиска пользователя настроен для глобального поиска домена в домене, а атрибут — sAMAccountName.
пример пути поиска:
dc=example,dc=com
LDAP authentication failed: LDAP account search for [user account]com error:Ldap Search Error: Not Unique
Cause
Проблема вызвана конфигурацией AD, в которой пользователь (пользователей) дважды находится в главном домене или поддомене, когда атрибут поиска — sAMAccountName.
Resolution
Рекомендуется указать путь для поиска пользователя и группы к определенному подразделению или каталогу, а не к глобальному поиску. Если среда LDAP не поддерживает эту функцию из-за того, что пользователи находятся в другом OU, изменение идентификатора атрибута с sAMAccountName на userPrincipalName с расширенной настройки LDAP упростит эту проблему.
ПРИМЕЧАНИЕ: Пользователю потребуется войти в систему, используя полное доменное имя (FQDN) Joe_Doe@example.com.
Изменение идентификатора атрибута для пути поиска пользователя LDAP до версии 3.5 с кодом
1. Войдите в графический интерфейс пользователя
PowerStore 2. Нажмите кнопку справа вверху
3. На левой панели прокрутите вниз до тех пор, пока не найдете службу каталогов
4. Нажмите изменить конфигурацию LDAP
5. В левом углу вы увидите дополнительные настройки, нажмите на синюю ссылку
6. Найдите идентификатор атрибута ниже пути поиска. по умолчанию используется значение sAMAccountName
7. Измените значение на userPrincipalName
8. Проверьте подключение и повторите
попытку Изменение идентификатора атрибута для пути поиска пользователя LDAP на код 3.5 или более поздней
версии 1. Войдите в графический интерфейс пользователя
PowerStore 2. Нажмите кнопку справа вверху
3. На левой панели прокрутите вниз до тех пор, пока не найдете аутентификацию в разделе Безопасность
4. Нажмите изменить конфигурацию LDAP
5. В левом углу вы увидите дополнительные настройки, нажмите на синюю ссылку
6. Найдите идентификатор атрибута ниже пути поиска. по умолчанию используется значение sAMAccountName
7. Измените значение на userPrincipalName
8. Проверка подключения и повторная попытка
ПРИМЕЧАНИЕ: Пользователю потребуется войти в систему, используя полное доменное имя (FQDN) Joe_Doe@example.com.
Изменение идентификатора атрибута для пути поиска пользователя LDAP до версии 3.5 с кодом
1. Войдите в графический интерфейс пользователя
PowerStore 2. Нажмите кнопку справа вверху
3. На левой панели прокрутите вниз до тех пор, пока не найдете службу каталогов
4. Нажмите изменить конфигурацию LDAP
5. В левом углу вы увидите дополнительные настройки, нажмите на синюю ссылку
6. Найдите идентификатор атрибута ниже пути поиска. по умолчанию используется значение sAMAccountName
7. Измените значение на userPrincipalName
8. Проверьте подключение и повторите
попытку Изменение идентификатора атрибута для пути поиска пользователя LDAP на код 3.5 или более поздней
версии 1. Войдите в графический интерфейс пользователя
PowerStore 2. Нажмите кнопку справа вверху
3. На левой панели прокрутите вниз до тех пор, пока не найдете аутентификацию в разделе Безопасность
4. Нажмите изменить конфигурацию LDAP
5. В левом углу вы увидите дополнительные настройки, нажмите на синюю ссылку
6. Найдите идентификатор атрибута ниже пути поиска. по умолчанию используется значение sAMAccountName
7. Измените значение на userPrincipalName
8. Проверка подключения и повторная попытка
Affected Products
Entry Level & Midrange, PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 1200T, PowerStore 3000X, PowerStore 3000T, PowerStore 3200T, PowerStore 5000X, PowerStore 5000TProducts
Storage, PowerStore 500T, PowerStore 5200T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T, PowerStore 9200T, PowerStoreOSArticle Properties
Article Number: 000215510
Article Type: Solution
Last Modified: 29 Sept 2023
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.