PowerStore: Belirli LDAP'ler, GUI'den genel kimlik doğrulama hatası ve "Günlüklerden benzersiz değil" ile PowerStore GUi'de oturum açamıyor

Summary: PowerStore: Belirli LDAP'ler, GUI'den genel kimlik doğrulama hatası ve günlüklerden "Benzersiz Değil" hatasıyla PowerStore GUI'de oturum açamıyor

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Bazı kullanıcılar oturum açarken diğer kullanıcılar oturum açamıyor.
Müşterinin ana etki alanında ve/veya alt etki alanında birden fazla hesabı vardır. Örnek:
Joe Doe, ana etki alanı denetleyicisinin example.com
Aynı zamanda Ayla Doe alt etki alanı sub.example.com parçasıdır (bu, example.com'nin alt etki alanıdır) 
Kullanıcıarama yolu , etki alanında genel etki alanı araması için yapılandırılmış ve öznitelik sAMAccountName'dir.
arama yolu örneği:
dc=example,dc=com
Günlüklerde bulunan LDAP hatası:
LDAP authentication failed: LDAP account search for [user account]com error:Ldap Search Error: Not Unique 

Cause

Sorun, arama özniteliği sAMAccountName olduğunda kullanıcının ana etki alanında veya alt etki alanında iki kez bulunduğu AD yapılandırmasından kaynaklanmaktadır.

Resolution

Genel arama yerine belirli bir kuruluş birimine (OU) veya dizine kullanıcı ve grup arama yolunu belirtmeniz önerilir. Kullanıcılar farklı OU'da olduğundan LDAP ortamı bunu desteklemezse öznitelik kimliğini sAMAccountName'den userPrincipalName'e LDAP gelişmiş ayarından değiştirme bu sorunu çözecektir.

NOT: Kullanıcının tam nitelikli etki alanı adını (FQDN) kullanarak oturum Joe_Doe@example.com.

LDAP kullanıcı arama yolu için Öznitelik Kimliğini 3.5 kod 1'den önce
değiştirme. PowerStore GUI 2'de
oturum açın. Sağ üstteki 3. ayara
tıklayın. Sol panelde, dizin hizmeti 4'i görene kadar aşağı
kaydırın. EDIT LDAP configuration 5 (LDAP yapılandırması 5'i düzenle
) öğesine tıklayın. Sol köşede gelişmiş ayarları görürsünüz. Mavi bağlantı 6'ya
tıklayın. Arama yolunun altında öznitelik kimliğini bulun. Varsayılan değer sAMAccountName
7'dir. Değeri userPrincipalName 8 olarak
ayarlayın. Bağlantıyı doğrulayın ve

3.5 kodunda veya sonraki 1'de LDAP kullanıcı arama yolu için Öznitelik Kimliğini değiştirme işlemini
yeniden deneyin. PowerStore GUI 2'de
oturum açın. Sağ üstteki 3. ayara
tıklayın. Güvenlik 4 altında kimlik doğrulamayı görene kadar sol panelde aşağı
kaydırın. EDIT LDAP configuration 5 (LDAP yapılandırması 5'i düzenle
) öğesine tıklayın. Sol köşede gelişmiş ayarları görürsünüz. Mavi bağlantı 6'ya
tıklayın. Arama yolunun altında öznitelik kimliğini bulun. Varsayılan değer sAMAccountName
7'dir. Değeri userPrincipalName 8 olarak
ayarlayın. Bağlantıyı doğrulayın ve yeniden deneme

Affected Products

Entry Level & Midrange, PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 1200T, PowerStore 3000X, PowerStore 3000T, PowerStore 3200T, PowerStore 5000X, PowerStore 5000T

Products

Storage, PowerStore 500T, PowerStore 5200T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T, PowerStore 9200T, PowerStoreOS
Article Properties
Article Number: 000215510
Article Type: Solution
Last Modified: 29 Sept 2023
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.