Сервер Windows: Кластеризована віртуальна машина відсутня в менеджері відмовостійких кластерів

Summary: Віртуальна машина (VM) у кластері Windows Server Hyper-V може відображатися не так, як очікувалося, у відмовостійкому диспетчері кластерів.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Принаймні одна кластеризована віртуальна машина не вказана на вкладці «Ролі» в Failover Cluster Manager. Відповідна віртуальна машина відображається в Hyper-V Manager на одному з вузлів кластера. Однак Hyper-V Manager вказує, що деякі налаштування віртуальної машини не можна змінити, оскільки вона кластеризована.

Cause

Це може статися, якщо коротке ім'я віртуальної машини змінилося з моменту її створення.

Resolution

Віртуальна машина, якої це стосується, може бути вказана на вкладці «Ролі» під іншою назвою. Це, швидше за все, відбувається на кластері, який розміщує багато віртуальних машин, ніж на кластері, який розміщує лише кілька. Щоб визначити, чи це так, виконайте такі дії:

  1. На вузлі кластера запустіть підвищений запит PowerShell.
  2. Виконайте команду:
Get-ClusterResource
  1. Перевірте стовпець «Ім'я» вихідного сигналу для ураженої віртуальної машини.
  2. Якщо уражена віртуальна машина вказана у виводі, вона присутня в кластері.
  3. Ім'я в стовпці «Група власників » показує ім'я, під яким віртуальна машина відображається в диспетчері відмовостійких кластерів. Якщо необхідно, переконайтеся, що це правильна віртуальна машина, підключившись до неї.
  4. У Failover Cluster Manager клацніть правою кнопкою миші віртуальну машину (використовуючи ім'я, показане на кроці 5) і виберіть «Властивості».
  5. Виправте коротке ім'я віртуальної машини та натисніть OK. Тепер його слід вказати, як і очікувалося.

Affected Products

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022

Products

PowerEdge FC640, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX5016s, PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360 , PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000216625
Article Type: Solution
Last Modified: 16 Dec 2024
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.