Windows Server:故障切换群集管理器中缺少群集虚拟机

Summary: Windows Server Hyper-V 群集中的虚拟机 (VM) 可能不会按预期显示在故障转移群集管理器中。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

故障切换群集管理器的“角色”选项卡中未列出至少一个群集虚拟机。有问题的虚拟机显示在其中一个群集节点上的 Hyper-V 管理器中。但是,Hyper-V Manager 指示虚拟机的某些设置无法修改,因为它是群集的。

Cause

如果 VM 的显示名称自创建以来已更改,则可能会发生这种情况。

Resolution

受影响的虚拟机可能以不同的名称列在“角色”选项卡中。与仅托管少量虚拟机的群集相比,在托管许多虚拟机的群集上更有可能发生这种情况。若要确定是否是这种情况,请按照下列步骤作:

  1. 在群集节点上,启动提升的 PowerShell 提示符。
  2. 运行命令:
Get-ClusterResource
  1. 检查受影响虚拟机的输出的 Name 列。
  2. 如果受影响的虚拟机在输出中列出,则它存在于群集中。
  3. OwnerGroup列中的名称显示虚拟机在故障转移群集管理器中列出的名称。如有必要,请通过连接到虚拟机来确认它是正确的虚拟机。
  4. 在故障转移群集管理器中,右键单击虚拟机(使用步骤 5 中显示的名称),然后选择属性
  5. 更正虚拟机的显示名称,然后单击 确定。它现在应按预期列出。

Affected Products

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022

Products

PowerEdge FC640, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX5016s, PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360 , PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000216625
Article Type: Solution
Last Modified: 16 Dec 2024
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.