PowerProtect Data Manager – omkonfiguration av OKTA SSO efter uppgradering
Summary: OKTA SSO fungerar inte efter PowerProtect Data Manager-uppdatering från 19.13 till 19.14. Snabbkorrigeringen tillämpas på PowerProtect Data Manager 19.13 som (PPDMESC-3304)
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
aaa.log:
./aaa.2023-08-23.0.log.gz:org.springframework.security.oauth2.jwt.JwtException: An error occurred while attempting to decode the Jwt: Signed JWT rejected: Another algorithm expected, or no matching keys found
Cause
Felet i aaa.log:
2023-08-24T07:39:26.964Z ERROR [] [https-jsse-nio-9090-exec-1] [][][][TRACE_ID:97d2704ca1652f50][] [c.e.b.a.s.s.DefaultSsoService.lambda$1(71)] - SSO login issue: {}
org.springframework.security.oauth2.jwt.JwtException: An error occurred while attempting to decode the Jwt: Signed JWT rejected: Another algorithm expected, or no matching keys found
Det betyder att AAA förväntar sig HS256 som standard, men OKTA returnerar alltid en RS256-signatur.
Resolution
- Logga in på PowerProtect Data Manager ssh
cd /usr/local/brs/lib/aaa/configvim application-sso.properties- Kontrollera om variabeln aaa.sso.client.alg=RS256, om inte, byt från HS256 till RS256.
- Avsluta vim (:wq!)
- AAA OMSTART
Article Properties
Article Number: 000218197
Article Type: Solution
Last Modified: 18 Mar 2025
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.