PowerProtect Data Manager - アップグレード後のOKTA SSOの再構成
Summary: PowerProtect Data Manager 19.13から19.14にアップデートした後、Okta SSOが機能しません。 ホットフィックスがPowerProtect Data Manager 19.13に適用されます(PPDMESC-3304)
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
aaa.log:
./aaa.2023-08-23.0.log.gz:org.springframework.security.oauth2.jwt.JwtException: An error occurred while attempting to decode the Jwt: Signed JWT rejected: Another algorithm expected, or no matching keys found
Cause
aaa.logのエラー:
2023-08-24T07:39:26.964Z ERROR [] [https-jsse-nio-9090-exec-1] [][][][TRACE_ID:97d2704ca1652f50][] [c.e.b.a.s.s.DefaultSsoService.lambda$1(71)] - SSO login issue: {}
org.springframework.security.oauth2.jwt.JwtException: An error occurred while attempting to decode the Jwt: Signed JWT rejected: Another algorithm expected, or no matching keys found
これは、AAA がデフォルトである HS256 を期待していることを意味しますが、OKTA は常に RS256 署名を返します。
Resolution
- PowerProtect Data Manager sshへのログイン
cd /usr/local/brs/lib/aaa/configvim application-sso.properties- 変数aaa.sso.client.alg=RS256かどうかを確認します。そうでない場合は、HS256からRS256に変更します。
- vimを終了(:wq!)
- aaa 再起動
Article Properties
Article Number: 000218197
Article Type: Solution
Last Modified: 18 Mar 2025
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.