PowerProtect Data Manager - 업그레이드 후 OKTA SSO 재구성
Summary: PowerProtect Data Manager를 19.13에서 19.14로 업데이트한 후 OKTA SSO가 작동하지 않습니다. 핫픽스는 PowerProtect Data Manager 19.13에 다음과 같이 적용됩니다(PPDMESC-3304).
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
aaa.log:
./aaa.2023-08-23.0.log.gz:org.springframework.security.oauth2.jwt.JwtException: An error occurred while attempting to decode the Jwt: Signed JWT rejected: Another algorithm expected, or no matching keys found
Cause
aaa.log의 오류 :
2023-08-24T07:39:26.964Z ERROR [] [https-jsse-nio-9090-exec-1] [][][][TRACE_ID:97d2704ca1652f50][] [c.e.b.a.s.s.DefaultSsoService.lambda$1(71)] - SSO login issue: {}
org.springframework.security.oauth2.jwt.JwtException: An error occurred while attempting to decode the Jwt: Signed JWT rejected: Another algorithm expected, or no matching keys found
즉, AAA는 기본값인 HS256을 예상하지만 OKTA는 항상 RS256 서명을 반환합니다.
Resolution
- PowerProtect Data Manager에 로그인 SSH
cd /usr/local/brs/lib/aaa/configvim application-sso.properties- 변수 aaa.sso.client.alg=RS256인지 확인하고, 그렇지 않은 경우 HS256에서 RS256으로 변경합니다.
- vim에서 종료하십시오 (: wq!)
- aaa 재시작
Article Properties
Article Number: 000218197
Article Type: Solution
Last Modified: 18 Mar 2025
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.